summaryrefslogtreecommitdiffstats
path: root/abs/core/mplayer/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mplayer/PKGBUILD')
-rw-r--r--abs/core/mplayer/PKGBUILD145
1 files changed, 93 insertions, 52 deletions
diff --git a/abs/core/mplayer/PKGBUILD b/abs/core/mplayer/PKGBUILD
index c725fc3..51b3da6 100644
--- a/abs/core/mplayer/PKGBUILD
+++ b/abs/core/mplayer/PKGBUILD
@@ -1,73 +1,114 @@
-# $Id: PKGBUILD 163158 2012-07-08 09:32:14Z ibiru $
-# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# $Id$
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgbase=mplayer
pkgname=('mplayer' 'mencoder')
-pkgver=35014
+pkgver=37051
pkgrel=1
arch=('i686' 'x86_64')
-makedepends=('libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient'
-'aalib' 'libcaca' 'x264' 'faac' 'faad2' 'lirc-utils' 'enca' 'libvdpau' 'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx'
- 'fribidi' 'unzip' 'mesa' 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray' 'libcdio' 'subversion')
+makedepends=(
+ 'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
+ 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'libcaca'
+ 'x264' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
+ 'libdca' 'a52dec' 'schroedinger' 'libvpx' 'fribidi' 'unzip' 'mesa'
+ 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
+ 'libcdio-paranoia' 'opus'
+)
license=('GPL')
-url="http://www.mplayerhq.hu/"
-options=(!buildflags !emptydirs)
-source=(ftp://ftp.archlinux.org/other/$pkgbase/$pkgbase-$pkgver.tar.xz mplayer.desktop)
-md5sums=('d0785560e5e8eb02e089728ef4412eae'
- 'c0d6ef795cf6de48e3b87ff7c23f0319')
+url='http://www.mplayerhq.hu/'
+options=('!buildflags' '!emptydirs')
+source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
+ http://ffmpeg.org/releases/ffmpeg-2.2.tar.bz2
+ mplayer.desktop
+ cdio-includes.patch
+ include-samba-4.0.patch)
+md5sums=('SKIP'
+ '744febca199548c9393b1f1ed05ccdd8'
+ '62f44a58f072b2b1a3c3d3e4976d64b3'
+ '7b5be7191aafbea64218dc4916343bbc'
+ '868a92bdef148df7f38bfa992b26ce9d')
+
+#pkgver() {
+# cd $pkgbase-$pkgver
+# svnversion
+#}
+
+prepare() {
+ cd $pkgbase-$pkgver
+ mv ../ffmpeg-2.2 ./ffmpeg
+
+ patch -p0 -i ../cdio-includes.patch
+ patch -p1 -i ../include-samba-4.0.patch
+
+ ./version.sh
+}
build() {
- cd "$srcdir/$pkgbase"
+ cd $pkgbase-$pkgver
- ./configure --prefix=/usr \
- --enable-runtime-cpudetection \
- --disable-gui \
- --disable-arts \
- --disable-liblzo \
- --disable-speex \
- --disable-openal \
- --disable-libdv \
- --disable-musepack \
- --disable-esd \
- --disable-mga \
- --disable-ass-internal \
- --disable-cdparanoia \
- --enable-radio \
- --language=all \
- --confdir=/etc/mplayer
- [ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
+ ./configure --prefix=/usr \
+ --enable-runtime-cpudetection \
+ --disable-gui \
+ --disable-arts \
+ --disable-liblzo \
+ --disable-speex \
+ --disable-openal \
+ --disable-libdv \
+ --disable-musepack \
+ --disable-esd \
+ --disable-mga \
+ --disable-ass-internal \
+ --disable-cdparanoia \
+ --enable-xvmc \
+ --enable-radio \
+ --enable-radio-capture \
+ --enable-smb \
+ --language=all \
+ --confdir=/etc/mplayer
+ [[ "$CARCH" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
- make
+ make
}
package_mplayer() {
- pkgdesc="A movie player for linux"
- install=mplayer.install
- backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
- depends=('desktop-file-utils' 'ttf-dejavu' 'enca' 'libxss' 'a52dec' 'libvpx' 'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig' 'libgl'
- 'libxinerama' 'libvdpau' 'smbclient' 'xvidcore' 'opencore-amr' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga' 'fribidi'
- 'libjpeg' 'faac' 'faad2' 'schroedinger' 'mpg123' 'libass' 'libxxf86vm' 'libbluray' 'libcdio')
+ pkgdesc='Media player for Linux'
+ install=mplayer.install
+ backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
+ depends=(
+ 'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
+ 'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
+ 'libgl' 'libxinerama' 'libvdpau' 'smbclient' 'xvidcore'
+ 'opencore-amr' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
+ 'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
+ 'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus'
+ )
+
+ cd $pkgbase-$pkgver
+ make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
- cd "$srcdir/$pkgbase"
+ install -Dm644 etc/{codecs.conf,input.conf,example.conf} \
+ "$pkgdir/etc/mplayer/"
- make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
- install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
- install -dm755 "$pkgdir/usr/share/mplayer/"
- ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
- rm -rf "$pkgdir/usr/share/mplayer/font"
- #desktop file FS#14770
- install -Dm644 "$srcdir/mplayer.desktop" "$pkgdir/usr/share/applications/mplayer.desktop"
- install -Dm644 etc/mplayer256x256.png "$pkgdir/usr/share/pixmaps/mplayer.png"
+ # desktop file (FS#14770)
+ install -Dm644 ../mplayer.desktop \
+ "$pkgdir"/usr/share/applications/mplayer.desktop
+ install -Dm644 etc/mplayer256x256.png \
+ "$pkgdir"/usr/share/pixmaps/mplayer.png
}
package_mencoder() {
- pkgdesc="Free command line video decoding, encoding and filtering tool"
- depends=('enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame' 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore' 'opencore-amr'
- 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2' 'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio')
+ pkgdesc='Free command line video decoding, encoding and filtering tool'
+ depends=(
+ 'enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame'
+ 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
+ 'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
+ 'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
+ 'libvorbis' 'opus'
+ )
- cd "$srcdir/$pkgbase"
- make DESTDIR="$pkgdir" install-mencoder install-mencoder-man
- #find "$pkgdir/usr/share/man" -name 'mplayer.1.gz' -exec bash -c 'mv "$1" "${1/mplayer/mencoder}"' _ {} \;
- rm -rf $pkgdir/usr/share/man
+ make -C $pkgbase-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man
+ #find "$pkgdir"/usr/share/man -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
+ rm -rf $pkgdir/usr/share/man
}