summaryrefslogtreecommitdiffstats
path: root/abs/core/mplayer
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mplayer')
-rw-r--r--abs/core/mplayer/PKGBUILD33
-rw-r--r--abs/core/mplayer/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch41
-rw-r--r--abs/core/mplayer/giflib51.patch24
3 files changed, 58 insertions, 40 deletions
diff --git a/abs/core/mplayer/PKGBUILD b/abs/core/mplayer/PKGBUILD
index fbf15d9..d282afc 100644
--- a/abs/core/mplayer/PKGBUILD
+++ b/abs/core/mplayer/PKGBUILD
@@ -1,37 +1,38 @@
# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgbase=mplayer
pkgname=('mplayer' 'mencoder')
-pkgver=37224
-pkgrel=5
+pkgver=37379
+pkgrel=6
arch=('i686' 'x86_64')
makedepends=(
'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'libcaca'
- 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
+ 'faac' 'faad2' 'lirc' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
'libdca' 'a52dec' 'schroedinger' 'libvpx' 'fribidi' 'unzip' 'mesa'
'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
- 'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gsm'
+ 'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gnutls'
+ 'gsm' 'libdvdcss' 'libdvdread' 'libdvdnav'
)
license=('GPL')
url='http://www.mplayerhq.hu/'
options=('!buildflags' '!emptydirs')
source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
- http://ffmpeg.org/releases/ffmpeg-2.2.10.tar.bz2
+ http://ffmpeg.org/releases/ffmpeg-2.6.2.tar.bz2
mplayer.desktop
cdio-includes.patch
include-samba-4.0.patch
- giflib51.patch
+ ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
revert-icl-fixes.patch)
md5sums=('SKIP'
- 'f40a829f5075c8ee901e5dbc6d40c209'
+ 'e75d598921285d6775f20164a91936ac'
'62f44a58f072b2b1a3c3d3e4976d64b3'
'7b5be7191aafbea64218dc4916343bbc'
'868a92bdef148df7f38bfa992b26ce9d'
- '14461fb94b7aa5dda091ba4f737df2d9'
+ '71be9bcd297cb9ce833bbc5d425c0470'
'3579402002b7302fdf2d146639333efd')
pkgver() {
@@ -41,12 +42,12 @@ pkgver() {
prepare() {
cd $pkgbase-$pkgver
- mv ../ffmpeg-2.2.10 ./ffmpeg
+ mv ../ffmpeg-*/ ./ffmpeg
- patch -p0 -i ../cdio-includes.patch
- patch -p1 -i ../include-samba-4.0.patch
- patch -Np0 -i ../giflib51.patch
+ patch -Np0 -i ../cdio-includes.patch
+ patch -Np1 -i ../include-samba-4.0.patch
patch -Np0 -i ../revert-icl-fixes.patch
+ patch -d ffmpeg -Np1 <../ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
./version.sh
}
@@ -84,12 +85,12 @@ package_mplayer() {
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
depends=(
'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
- 'lirc-utils' 'libx264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
+ 'lirc' 'libx264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
'libgl' 'libxinerama' 'libvdpau' 'smbclient' 'xvidcore'
'opencore-amr' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus' 'rtmpdump'
- 'gsm'
+ 'gsm' 'gnutls' 'libdvdnav'
)
cd $pkgbase-$pkgver
@@ -112,7 +113,7 @@ package_mencoder() {
'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
- 'libvorbis' 'opus' 'rtmpdump' 'gsm'
+ 'libvorbis' 'opus' 'rtmpdump' 'gsm' 'libdvdnav'
)
make -C $pkgbase-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man
diff --git a/abs/core/mplayer/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch b/abs/core/mplayer/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
new file mode 100644
index 0000000..15d2600
--- /dev/null
+++ b/abs/core/mplayer/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
@@ -0,0 +1,41 @@
+From 6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab Mon Sep 17 00:00:00 2001
+From: James Zern <jzern@google.com>
+Date: Mon, 19 Oct 2015 22:44:11 -0700
+Subject: [PATCH] libvpxenc: remove some unused ctrl id mappings
+
+VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
+from libvpx and the remaining values were never used here
+
+Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
+Signed-off-by: James Zern <jzern@google.com>
+---
+ libavcodec/libvpxenc.c | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
+index 5f39783..992122c 100644
+--- a/libavcodec/libvpxenc.c
++++ b/libavcodec/libvpxenc.c
+@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
+
+ /** String mappings for enum vp8e_enc_control_id */
+ static const char *const ctlidstr[] = {
+- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
+- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
+- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
+- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
+- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
+- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
+ [VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
+ [VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
+ [VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
+- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
+ [VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
+ [VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
+- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
+ [VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
+ [VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
+ [VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
+--
+1.7.10.4
+
diff --git a/abs/core/mplayer/giflib51.patch b/abs/core/mplayer/giflib51.patch
deleted file mode 100644
index e884b39..0000000
--- a/abs/core/mplayer/giflib51.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- libvo/vo_gif89a.c.orig 2014-06-11 10:06:29.243216331 +0000
-+++ libvo/vo_gif89a.c 2014-06-11 10:08:37.346078847 +0000
-@@ -75,6 +75,9 @@
- #define MakeMapObject GifMakeMapObject
- #define FreeMapObject GifFreeMapObject
- #define QuantizeBuffer GifQuantizeBuffer
-+#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
-+#define EGifCloseFile(a) EGifCloseFile(a, NULL)
-+#endif
- #endif
-
- // how many frames per second we are aiming for during output.
---- libmpdemux/demux_gif.c.orig 2014-06-11 10:46:48.120883788 +0000
-+++ libmpdemux/demux_gif.c 2014-06-11 10:47:28.290732272 +0000
-@@ -50,6 +50,9 @@
- #define DGifOpenFileHandle(a) DGifOpenFileHandle(a, NULL)
- #define GifError() (gif ? gif->Error : 0)
- #define GifErrorString() GifErrorString(gif->Error)
-+#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
-+#define DGifCloseFile(a) DGifCloseFile(a, NULL)
-+#endif
- #endif
-
- /* >= 4.2 prior GIFLIB did not have MAJOR/MINOR defines */