summaryrefslogtreecommitdiffstats
path: root/abs/core/mysql/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mysql/PKGBUILD')
-rw-r--r--abs/core/mysql/PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/abs/core/mysql/PKGBUILD b/abs/core/mysql/PKGBUILD
index 88460bc..11df8fb 100644
--- a/abs/core/mysql/PKGBUILD
+++ b/abs/core/mysql/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 2465 2008-06-02 11:38:50Z alexander $
+# $Id: PKGBUILD 23595 2009-01-11 13:14:19Z douglas $
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=mysql
-pkgver=5.0.60
-pkgrel=1
+pkgver=5.0.75
+pkgrel=3
pkgdesc="A fast SQL database server"
arch=(i686 x86_64)
backup=(etc/my.cnf etc/conf.d/mysqld)
@@ -11,8 +11,9 @@ depends=("mysql-clients>=${pkgver}" 'tcp_wrappers')
makedepends=('libtool')
url=('http://www.mysql.com/')
options=('!libtool')
+optdepends=('perl-dbi' 'perl-dbd-mysql')
license=('GPL')
-source=(http://mirror.provenscaling.com/mysql/enterprise/source/5.0/mysql-${pkgver}.tar.gz
+source=(ftp://ftp.pucpr.br/mysql/Downloads/MySQL-5.0/mysql-${pkgver}.tar.gz
mysql-no-clients.patch
mysqld
my.cnf
@@ -27,7 +28,7 @@ build() {
--with-innodb --enable-local-infile --with-openssl \
--with-charset=latin1 --with-collation=latin1_general_ci \
--with-extra-charsets=complex --enable-thread-safe-client \
- --with-libwrap --with-berkeley-db
+ --with-libwrap --with-berkeley-db --with-embedded-server
# fixes
sed -i -e 's/^.*HAVE_GETHOSTBYNAME_R_GLIBC2_STYLE.*$/#define\ HAVE_GETHOSTBYNAME_R_GLIBC2_STYLE/g' include/config.h || return 1
@@ -47,8 +48,3 @@ build() {
install -D -m644 ../mysqld.conf.d ${startdir}/pkg/etc/conf.d/mysqld
rm -f ${startdir}/pkg/usr/bin/mysql_config
}
-md5sums=('2709a53f3da6f1cd868825ed2ea80431'
- 'e892aac36cbeb57f0e003ec0936afb3b'
- '64d79a5a34043c1de949d734b720c217'
- '0ee035590ffc61d32de994f461fd2bd2'
- '4a9077fc95ec6db1d5420e0cdc74d31c')