summaryrefslogtreecommitdiffstats
path: root/abs/core/mythinstall/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythinstall/PKGBUILD')
-rw-r--r--abs/core/mythinstall/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
new file mode 100644
index 0000000..bd58a19
--- /dev/null
+++ b/abs/core/mythinstall/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Jams
+pkgname=mythinstall
+pkgver=1
+pkgrel=13
+pkgdesc="LinHES installer/systemconfig GUI."
+arch=i686
+depends=()
+makedepends=(mythtv)
+
+source=(autocard.cpp
+ autocard.h
+ infrared.cpp
+ infrared.h
+ installationtype.cpp
+ installationtype.h
+ installdialog.cpp
+ installdialog.h
+ installsettings.cpp
+ installsettings.h
+ main.cpp
+ misc_settings.cpp
+ misc_settings.h
+ mv_common.h
+ mythinstall.pro
+ password_manage.cpp
+ password_manage.h
+ settemplate.cpp
+ settemplate.h
+ statusbox.cpp
+ statusbox.h
+ xorgsettings.cpp
+ xorgsettings.h)
+
+build() {
+
+# It is assumed that you have built the mythtv package in the same
+# LinHES-PKGBUILD area.
+
+ cd ${srcdir}
+ qmake mythinstall.pro || return 1
+ make || return 1
+ MVBINDIR=$startdir/pkg/usr/MythVantage/bin
+ mkdir -p $MVBINDIR
+ install -m 0755 mythinstall $MVBINDIR/MythVantage
+ cd $MVBINDIR
+ ln -s MythVantage mythvantage
+ ln -s MythVantage mythinstall
+ cd -
+}