summaryrefslogtreecommitdiffstats
path: root/abs/core/mythinstall
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythinstall')
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/autocard.cpp2
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installationtype.cpp11
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp4
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp2
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/xorgsettings.cpp4
-rw-r--r--abs/core/mythinstall/PKGBUILD2
6 files changed, 14 insertions, 11 deletions
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/autocard.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/autocard.cpp
index 7808eac..c0c859f 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/autocard.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/autocard.cpp
@@ -17,7 +17,7 @@ void AutoCard::popup_menu(void)
QString uniqid = name.section(' ', -1);
QString description = name.section('*',-3,-3);
description = description.section('.',1);
- description = description.trimmed();
+ description = description.simplified();
// //cout << uniqid << endl;
// //cout << "descriptn" << endl;
// //cout << description << endl;
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installationtype.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installationtype.cpp
index 9fa3b1a..96866dc 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installationtype.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installationtype.cpp
@@ -6,7 +6,6 @@
#include <qdir.h>
#include "mv_common.h"
-
int mythinstalltype (QString tmp_install_drive)
{
@@ -97,17 +96,21 @@ static HostSpinBox *HOSTSWAPsize()
line = t.readLine();
if ( line.startsWith("MemTotal:"))
{
- currentitem = line.trimmed();
+ currentitem = line.simplified();
currentitem = currentitem.section( " ", 1, 1 );
}
}
file.close();
bool ok;
int mem = currentitem.toInt( &ok, 10 ); // dec == 0, ok == FALSE
+ //QTextStream(stdout) << mem << endl;
mem = mem/1024 ;
+ //QTextStream(stdout) << mem << endl;
+
if ( ! ok )
- mem = 120 ;
- HostSpinBox *gc = new HostSpinBox("HOSTSWAPsize", 128, 128000, 128, true);
+ mem = 257 ;
+ //QTextStream(stdout) << mem << endl;
+ HostSpinBox *gc = new HostSpinBox("HOSTSWAPsize", 256, 256000, 256, true);
gc->setLabel(QObject::tr("Swapspace size (MB)"));
gc->setValue(mem);
gc->setHelpText(QObject::tr("Amount of space allocated for the swap partition." ));
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
index 776a36b..1724da7 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
@@ -99,7 +99,7 @@ bool WelcomeDialog::Create(void)
void WelcomeDialog::shutdownNow(int rc)
{
QString NETBOOT = getenv("NETBOOT");
- NETBOOT=NETBOOT.trimmed();
+ NETBOOT=NETBOOT.simplified();
// system("rm -f /tmp/.install_state");
// system("rm -f /tmp/.install_percent");
// system("rm -f /tmp/.install_error");
@@ -559,7 +559,7 @@ void WelcomeDialog::showPopup_2(void)
bool installsource = false;
QString NETBOOT = getenv("NETBOOT");
- NETBOOT=NETBOOT.trimmed();
+ NETBOOT=NETBOOT.simplified();
if ( NETBOOT == "YES" )
m_menuPopup->AddButton(("Diskless Frontend " ), SLOT(install_net() ) );
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 7d204d7..aa599ee 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -481,7 +481,7 @@ static HostComboBox *HostMysqlserverip_listbox()
gc->setHelpText(QObject::tr("The IP address of the MasterBackend MySQL server."));
QString NETBOOT = getenv("NETBOOT");
- NETBOOT=NETBOOT.trimmed();
+ NETBOOT=NETBOOT.simplified();
if ( NETBOOT != "YES" )
{
if ( ((gCoreContext->GetSetting("HostaccesshostypeSystemtype")) == "0" ))
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/xorgsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/xorgsettings.cpp
index d8f35af..eb6c893 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/xorgsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/xorgsettings.cpp
@@ -602,9 +602,9 @@ AdvancedXSettings::AdvancedXSettings():
HostXIgnoreConfig->setLabel(QObject::tr("User Supplied Configuration"));
HostXIgnoreConfig->setValue(false);
#ifdef __MVAPP__
- HostXIgnoreConfig->setHelpText(QObject::tr("If checked, the system will use the configuration file provided by YOU. Place your configuration file in /data/home/mythtv/templates/xorg.user."));
+ HostXIgnoreConfig->setHelpText(QObject::tr("If checked, the system will use the configuration file provided by YOU. Place your configuration file in /home/mythtv/templates/xorg.user."));
#else
- HostXIgnoreConfig->setHelpText(QObject::tr("If checked, the system will use the configuration file provided by YOU. Place your configuration file in /data/home/mythtv/templates/xorg.user."));
+ HostXIgnoreConfig->setHelpText(QObject::tr("If checked, the system will use the configuration file provided by YOU. Place your configuration file in /home/mythtv/templates/xorg.user."));
#endif
Setting* Advancedxsettings = HostXIgnoreConfig;
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index 99e4720..45b963d 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=8.4
-pkgrel=3
+pkgrel=4
pkgdesc="LinHES installer/systemconfig GUI."
arch=('i686' 'x86_64')
depends=('mythtv>=0.28')