summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/old/stable-0.21/mythbrowser/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/old/stable-0.21/mythbrowser/PKGBUILD')
-rw-r--r--abs/core/mythtv/old/stable-0.21/mythbrowser/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core/mythtv/old/stable-0.21/mythbrowser/PKGBUILD b/abs/core/mythtv/old/stable-0.21/mythbrowser/PKGBUILD
new file mode 100644
index 0000000..51a27d2
--- /dev/null
+++ b/abs/core/mythtv/old/stable-0.21/mythbrowser/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 7374 2008-07-31 06:53:36Z eric $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythbrowser
+pkgver=0.21
+pkgrel=6
+pkgdesc="Mini web browser for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'wget' 'libxvmc' 'kdelibs3' 'qt3')
+groups=('mythtv-extras')
+options=('!makeflags')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
+
+build() {
+ cd $startdir/src/mythplugins
+ . /etc/profile.d/qt3.sh
+ . /etc/profile.d/kde3.sh
+ svn update
+ sed -i 's#kde3#kde#' configure || return 1
+ ./configure --prefix=/usr --enable-opengl --disable-all --enable-mythbrowser || return 1
+
+ qmake mythplugins.pro || return 1
+ make qmake || return 1
+ sed -i 's#kde3#kde#' ./mythbrowser/mythbrowser/Makefile || return 1
+ make || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+