summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.23/morethemes
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable-0.23/morethemes')
-rwxr-xr-xabs/core/mythtv/stable-0.23/morethemes/PKGBUILD46
-rw-r--r--abs/core/mythtv/stable-0.23/morethemes/retro-wide_video-ui.xml-filetypes.patch22
2 files changed, 68 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable-0.23/morethemes/PKGBUILD b/abs/core/mythtv/stable-0.23/morethemes/PKGBUILD
new file mode 100755
index 0000000..9633db1
--- /dev/null
+++ b/abs/core/mythtv/stable-0.23/morethemes/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=morethemes
+pkgver=0.23
+pkgrel=29
+pkgdesc="Additional themes for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('mythtv')
+groups=('mythtv-extras')
+source=('ftp://ftp.knoppmyth.net/R6/sources/morethemes-0.23.tar.bz2'
+ 'ftp://miroku.no-ip.com/blue-abstract-wide.2010.05.26.tar.bz2'
+ 'http://elkin.de/mythtv/2010.06.13-Willi.tar.bz2'
+ 'http://elkin.de/mythtv/2010.03.13-bando-blue.tar.bz2'
+ 'http://www.mythtv.org/themes/LCARS.tar.gz'
+ 'http://www.mythtv.org/themes/TransBlue.tar.gz'
+ 'http://www.westnet.com/~chris/Mythtv/Retro-wide.tar.gz'
+ 'retro-wide_video-ui.xml-filetypes.patch')
+
+build() {
+
+ cd $startdir/src/
+ mkdir -p $pkgdir/usr/share/mythtv
+ cp -a themes $pkgdir/usr/share/mythtv
+ chmod 644 -R blue-abstract-wide
+ chmod +X -R blue-abstract-wide
+ cp -a blue-abstract-wide $pkgdir/usr/share/mythtv/themes
+ chmod 644 -R Willi
+ chmod +X -R Willi
+ cp -a Willi $pkgdir/usr/share/mythtv/themes
+ chmod 644 -R bando-blue
+ chmod +X -R bando-blue
+ cp -a bando-blue $pkgdir/usr/share/mythtv/themes
+ cp -a LCARS $pkgdir/usr/share/mythtv/themes
+ cp -a TransBlue $pkgdir/usr/share/mythtv/themes
+ cp -a Retro-wide $pkgdir/usr/share/mythtv/themes
+ cd $pkgdir/usr/share/mythtv/themes/Retro-wide
+ patch -p0 <${srcdir}/retro-wide_video-ui.xml-filetypes.patch
+}
+md5sums=('5672c0e8604f7b1610fa9a1c7626423c'
+ 'ddc9c7c481664df048b83b7de0731c44'
+ '3c9fbcc9495eb2b0a0fd5ae61acc779a'
+ 'c6d90fb469bc30a94e32f76c82122dd3'
+ 'a36bb7b2597a44128401b1aba9106122'
+ '21d6f967631e45b7039b965a63755282'
+ '526e806848cd4d0ae57883ba18edc6af'
+ '45ff91449f31ac2546c82f559d2e8394')
diff --git a/abs/core/mythtv/stable-0.23/morethemes/retro-wide_video-ui.xml-filetypes.patch b/abs/core/mythtv/stable-0.23/morethemes/retro-wide_video-ui.xml-filetypes.patch
new file mode 100644
index 0000000..e5465dc
--- /dev/null
+++ b/abs/core/mythtv/stable-0.23/morethemes/retro-wide_video-ui.xml-filetypes.patch
@@ -0,0 +1,22 @@
+--- video-ui.xml.orig 2010-07-04 06:21:18.000000000 +0000
++++ video-ui.xml 2010-07-04 06:22:22.000000000 +0000
+@@ -967,14 +967,17 @@
+
+ <button name="done_button" from="basebutton">
+ <position>700,550</position>
++ <value>Done</value>
+ </button>
+
+ <button name="new_button" from="basebutton">
+- <position>600,550</position>
++ <position>400,550</position>
++ <value>New</value>
+ </button>
+
+ <button name="delete_button" from="basebutton">
+- <position>0,550</position>
++ <position>100,550</position>
++ <value>Delete</value>
+ </button>
+ </window>
+