summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25/mythweb
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable-0.25/mythweb')
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/PKGBUILD77
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/mythweb.include8
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/mythweb.install18
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf1
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/schedules.php.patch16
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/sorting.php.patch19
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/tv-schedules.php.patch15
7 files changed, 0 insertions, 154 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
deleted file mode 100644
index 9882ad8..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
+++ /dev/null
@@ -1,77 +0,0 @@
-pkgname=mythweb
-pkgver=0.25
-pkgrel=9
-
-commit_hash=`cat ../git_src/git_hash_web`
-
-pkgdesc="Web interface for MythTV's backend, $commit_hash"
-url="http://www.mythtv.org"
-license="GPL"
-arch=('i686' 'x86_64')
-
-depends=('mythtv>=0.25' 'lighttpd' 'php' 'supplemental-web')
-groups=('mythtv-extras')
-install=mythweb.install
-#http://code.mythtv.org/trac/ticket/10504
-#patches=(schedules.php.patch sorting.php.patch tv-schedules.php.patch)
-patches=(schedules.php.patch tv-schedules.php.patch)
-source=(`echo ${patches[@]:0}` mythweb.include mythweb_gen_light.conf)
-
-build() {
-
- if [ -e ${srcdir}/mythweb ]
- then
- rm -rf ${srcdir}/mythweb
- fi
-
- cd ${startdir}
- msg "copy in myth web src"
- cp -rp ../git_src/mythweb $srcdir
- cd ${srcdir}/${pkgbase}
-
-
-
- msg "The local files are updated."
-
-
- cd $srcdir/mythweb
-
-
-
- echo "--------------------------applying patches----------------------------------------------------"
- for i in `echo ${patches[@]:0} `
- do
- echo applying $i
- echo "-----------------------------"
- patch -Np0 -i ${srcdir}/$i || return 1
- done
- echo "--------------------------done applying patches-----------------------------------------------"
-
- [ "$CARCH" = "i686" ] && ARCH="i686"
- [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
-}
-
-package() {
- DOCROOT=/data/srv/httpd/mythweb
- mkdir -p $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
- rsync -arp --exclude .git --delete-excluded $srcdir/mythweb/* $pkgdir/$DOCROOT
- rm $pkgdir/$DOCROOT/README
- chown -R http:http $pkgdir/$DOCROOT
- chmod g+rw $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
-
- # mythweb modules_path fix for 0.24
- # http://code.mythtv.org/trac/ticket/9255
- cd ${pkgdir}/${DOCROOT}
- ln -s modules modules_path
-
- #install conf files for lighttpd
- mkdir -p $pkgdir/etc/lighttpd
- install -D -m 644 $srcdir/mythweb.include $pkgdir/etc/lighttpd/
- #gen_light_conf
- install -D -m0744 ${srcdir}/mythweb_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/mythweb.conf
-
-}
-md5sums=('392e570594859c026ac12194920246d8'
- '515e29fda503c199888a91553e1815a0'
- '7645a6399434cbba35639713ac5d88e0'
- 'df190116b3aba35720fb6631885f973f')
diff --git a/abs/core/mythtv/stable-0.25/mythweb/mythweb.include b/abs/core/mythtv/stable-0.25/mythweb/mythweb.include
deleted file mode 100644
index 18e9be1..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/mythweb.include
+++ /dev/null
@@ -1,8 +0,0 @@
-alias.url += ( "/mythweb" => "/data/srv/httpd/mythweb/")
-
-url.rewrite-once = (
-"^/{1,2}mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
-"^/{1,2}mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
-"^/{1,2}mythweb/(.+)$" => "/mythweb/mythweb.php/$1",
-"^/{1,2}mythweb/(.*)$" => "/mythweb/mythweb.php"
-) \ No newline at end of file
diff --git a/abs/core/mythtv/stable-0.25/mythweb/mythweb.install b/abs/core/mythtv/stable-0.25/mythweb/mythweb.install
deleted file mode 100644
index 0073499..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/mythweb.install
+++ /dev/null
@@ -1,18 +0,0 @@
-post_install() {
- gen_light_include.py
- /sbin/sv hup /service/lighttpd
-}
-post_upgrade() {
- post_install
-
-}
-
-post_remove() {
- gen_light_include.py
- echo
- echo "==> Forcing a re-read of lighttpd's configuration file."
- echo ""
- /sbin/sv hup /service/lighttpd
-#--
-
-}
diff --git a/abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf b/abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf
deleted file mode 100644
index ddf0d2f..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf
+++ /dev/null
@@ -1 +0,0 @@
-include "/etc/lighttpd/mythweb.include"
diff --git a/abs/core/mythtv/stable-0.25/mythweb/schedules.php.patch b/abs/core/mythtv/stable-0.25/mythweb/schedules.php.patch
deleted file mode 100644
index 1d41711..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/schedules.php.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-*** modules/tv/tmpl/default/schedules.php.old 2011-04-03 06:05:31.000000000 -0500
---- modules/tv/tmpl/default/schedules.php 2012-03-27 05:37:40.000000000 -0500
-***************
-*** 90,95 ****
---- 90,100 ----
- </tr>
- </thead>
- <?php
-+ // Hack: Disable warnings about "Creating default
-+ // object from empty value" from below line
-+ // "$schedule->channel->name = '[ '.t('Any').' ]';"
-+ ini_set('error_reporting', E_ERROR);
-+
- $prev_group = '';
- $cur_group = '';
- foreach ($the_schedules as $schedule) {
diff --git a/abs/core/mythtv/stable-0.25/mythweb/sorting.php.patch b/abs/core/mythtv/stable-0.25/mythweb/sorting.php.patch
deleted file mode 100644
index 2f76216..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/sorting.php.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-*** includes/sorting.php.old 2011-04-03 06:05:31.000000000 -0500
---- includes/sorting.php 2012-03-27 05:05:51.000000000 -0500
-***************
-*** 123,129 ****
- function by_user_choice(&$a, &$b) {
- foreach ($GLOBALS['user_sort_choice'] as $sort) {
- $function = 'by_'.$sort['field'];
-! $response = $function(&$a, &$b);
- // Identical response, go on to the next sort choice
- if (!$response)
- continue;
---- 123,129 ----
- function by_user_choice(&$a, &$b) {
- foreach ($GLOBALS['user_sort_choice'] as $sort) {
- $function = 'by_'.$sort['field'];
-! $response = $function($a, $b);
- // Identical response, go on to the next sort choice
- if (!$response)
- continue;
diff --git a/abs/core/mythtv/stable-0.25/mythweb/tv-schedules.php.patch b/abs/core/mythtv/stable-0.25/mythweb/tv-schedules.php.patch
deleted file mode 100644
index 29e4ccb..0000000
--- a/abs/core/mythtv/stable-0.25/mythweb/tv-schedules.php.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-*** modules/tv/schedules.php.orig 2012-06-05 09:05:32.935946957 +0200
---- modules/tv/schedules.php 2012-06-05 09:05:36.633022229 +0200
-***************
-*** 47,52 ****
---- 47,56 ----
- if (count($the_schedules))
- sort_programs($the_schedules, 'schedules_sortby');
-
-+ // Hack: Disable warnings about "Creating default
-+ // object from empty value" from below line
-+ // "$schedule->channel->name = '[ '.t('Any').' ]';"
-+ ini_set('error_reporting', E_ERROR);
- // Load the class for this page
- require_once tmpl_dir.'schedules.php';
-