summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.27/mythplugins
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable-0.27/mythplugins')
-rw-r--r--abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD23
-rw-r--r--abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch32
-rw-r--r--abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch27
-rw-r--r--abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch52
4 files changed, 127 insertions, 7 deletions
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
index 8a651cd..1747521 100644
--- a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
@@ -8,8 +8,8 @@ pkgname=('mytharchive'
'mythnews'
'mythweather'
'mythzoneminder')
-pkgver=0.27
-pkgrel=9
+pkgver=0.27.4
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
@@ -17,9 +17,10 @@ makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexi
'libvorbis' 'mesa' 'libgl' 'mplayer' "mythtv>=${pkgver}"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
- 'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python-imaging'
+ 'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python2-pillow'
'python-pycurl' 'zlib')
-source=('mythburn.py-aspectratio.patch')
+source=('mythburn.py-aspectratio.patch' 'archivemenu.xml.patch' 'archiveutils.xml.patch'
+ 'cdparanoia.patch')
build() {
if [ -e ${srcdir}/mythplugins ]
@@ -33,6 +34,9 @@ build() {
cp -rp ../git_src/mythtv/mythplugins $srcdir
cd ${srcdir}/${pkgbase}
+ msg "Patching configure"
+ patch -Np1 -i "$srcdir/cdparanoia.patch"
+
msg "Configuring mythplugins"
./configure --prefix=/usr \
--enable-all \
@@ -46,9 +50,11 @@ build() {
package_mytharchive() {
pkgdesc="Create DVDs or archive recorded shows in MythTV"
depends=('cdrkit' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' "mythtv>=${pkgver}"
- 'python-imaging')
+ 'mjpegtools' 'python2-pillow')
cd "${srcdir}/${_gitname}/${pkgbase}/mytharchive"
patch mythburn/scripts/mythburn.py < $srcdir/mythburn.py-aspectratio.patch || return 1
+ patch theme/menus/archivemenu.xml < $srcdir/archivemenu.xml.patch || return 1
+ patch theme/menus/archiveutils.xml < $srcdir/archiveutils.xml.patch || return 1
make INSTALL_ROOT="${pkgdir}" install || return 1
}
@@ -75,7 +81,7 @@ package_mythgame() {
package_mythmusic() {
pkgdesc="Music playing plugin for MythTV"
- depends=('cdparanoia' 'fftw' 'flac' 'libcdaudio' 'libcdio'
+ depends=('cdparanoia' 'fftw' 'flac' 'libcdaudio' 'libcdio-paranoia'
'libvisual-plugins' 'libvorbis' "mythtv>=${pkgver}" 'taglib')
cd "${srcdir}/${_gitname}/${pkgbase}/mythmusic"
make INSTALL_ROOT="${pkgdir}" install || return 1
@@ -113,4 +119,7 @@ package_mythzoneminder() {
make INSTALL_ROOT="${pkgdir}" install || return 1
}
-md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2')
+md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2'
+ '0364d2613f22943f3d4c9d5ee43c1982'
+ '1063cf62878cd341476f28f63cb12782'
+ '5de8dd79d0b8a2b006f3c3258938b6b7')
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch b/abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch
new file mode 100644
index 0000000..f53e9d0
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch
@@ -0,0 +1,32 @@
+--- archivemenu.xml.orig 2014-02-11 23:01:41.292364208 +0000
++++ archivemenu.xml 2014-02-11 23:02:13.544892518 +0000
+@@ -3,12 +3,14 @@
+ <button>
+ <type>ARCHIVE_CREATE_DVD</type>
+ <text>Create DVD</text>
++ <description>Save recordings and videos to video DVD</description>
+ <action>ARCHIVE_CREATE_DVD</action>
+ </button>
+
+ <button>
+ <type>ARCHIVE_CREATE_ARCHIVE</type>
+ <text>Create Archive</text>
++ <description>Save recordings and videos to a native archive</description>
+ <action>ARCHIVE_CREATE_ARCHIVE</action>
+ </button>
+
+@@ -22,12 +24,14 @@
+ <button>
+ <type>ARCHIVE_IMPORT_VIDEO</type>
+ <text>Import Archive</text>
++ <description>Import recordings from a native archive</description>
+ <action>ARCHIVE_IMPORT_VIDEO</action>
+ </button>
+
+ <button>
+ <type>ARCHIVE_UTILITIES</type>
+ <text>Archive Utilities</text>
++ <description>Utilities for MythArchive</description>
+ <action>MENU archiveutils.xml</action>
+ </button>
+
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch b/abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch
new file mode 100644
index 0000000..9c17678
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch
@@ -0,0 +1,27 @@
+--- archiveutils.xml.orig 2014-02-11 23:01:41.292364208 +0000
++++ archiveutils.xml 2014-02-11 23:02:13.544892518 +0000
+@@ -2,19 +2,22 @@
+
+ <button>
+ <type>ARCHIVE_LAST_LOG</type>
+- <text>Show Log Viewer</text>
++ <text>Log Viewer</text>
++ <description>Show the Archive Log Viewer</description>
+ <action>ARCHIVE_LAST_LOG</action>
+ </button>
+
+ <button>
+ <type>ARCHIVE_TEST_DVD</type>
+ <text>Play Created DVD</text>
++ <description>Play the last created archive DVD</description>
+ <action>ARCHIVE_TEST_DVD</action>
+ </button>
+
+ <button>
+ <type>ARCHIVE_BURN_DVD</type>
+- <text>Burn DVD</text>
++ <text>Burn Created DVD</text>
++ <description>Burn the last created archive to DVD</description>
+ <action>ARCHIVE_BURN_DVD</action>
+ </button>
+
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch b/abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch
new file mode 100644
index 0000000..b4d1449
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch
@@ -0,0 +1,52 @@
+diff -Nru a/configure b/configure
+--- a/configure 2012-10-02 23:30:24.000000000 +1300
++++ b/configure 2013-01-09 14:54:40.448916370 +1300
+@@ -649,7 +649,7 @@
+ echo "MythMusic requires FLAC."
+ fi
+
+- if ! check_lib cdio/cdio.h cdio_open -lcdio || ! check_lib cdio/cdda.h cdio_cddap_open -lcdio_cdda || ! check_lib cdio/paranoia.h cdio_paranoia_init -lcdio_paranoia ; then
++ if ! check_lib cdio/cdio.h cdio_open -lcdio || ! check_lib cdio/paranoia/cdda.h cdio_cddap_open -lcdio_cdda || ! check_lib cdio/paranoia/paranoia.h cdio_paranoia_init -lcdio_paranoia ; then
+ disable cdio
+ fi
+
+diff -Nru a/mythmusic/mythmusic/cddecoder.cpp b/mythmusic/mythmusic/cddecoder.cpp
+--- a/mythmusic/mythmusic/cddecoder.cpp 2012-10-02 23:30:24.000000000 +1300
++++ b/mythmusic/mythmusic/cddecoder.cpp 2013-01-09 14:53:37.031690618 +1300
+@@ -14,7 +14,7 @@
+ #include <QString>
+
+ // libcdio
+-#include <cdio/cdda.h>
++#include <cdio/paranoia/cdda.h>
+ #include <cdio/logging.h>
+
+ // MythTV
+diff -Nru a/mythmusic/mythmusic/cddecoder.h b/mythmusic/mythmusic/cddecoder.h
+--- a/mythmusic/mythmusic/cddecoder.h 2012-10-02 23:30:24.000000000 +1300
++++ b/mythmusic/mythmusic/cddecoder.h 2013-01-09 14:53:12.328140979 +1300
+@@ -11,8 +11,8 @@
+ #endif
+
+ #ifdef HAVE_CDIO
+-# include <cdio/cdda.h>
+-# include <cdio/paranoia.h>
++# include <cdio/paranoia/cdda.h>
++# include <cdio/paranoia/paranoia.h>
+ #endif
+
+ class Metadata;
+diff -Nru a/mythmusic/mythmusic/cdrip.cpp b/mythmusic/mythmusic/cdrip.cpp
+--- a/mythmusic/mythmusic/cdrip.cpp 2012-10-02 23:30:24.000000000 +1300
++++ b/mythmusic/mythmusic/cdrip.cpp 2013-01-09 14:54:11.815330268 +1300
+@@ -8,8 +8,8 @@
+
+ #include "config.h"
+ #ifdef HAVE_CDIO
+-# include <cdio/cdda.h>
+-# include <cdio/paranoia.h>
++# include <cdio/paranoia/cdda.h>
++# include <cdio/paranoia/paranoia.h>
+ #endif //def HAVE_CDIO
+
+ // C++ includes