summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable-29/mythplugins/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable-29/mythplugins/PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
index ed4036c..7dcae9e 100644
--- a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
@@ -9,22 +9,23 @@ pkgname=('mytharchive'
'mythweather'
'mythzoneminder')
pkgver=29.1
-pkgrel=1
-arch=('i686' 'x86_64')
+pkgrel=9
+arch=('x86_64')
url="http://www.mythtv.org"
license=('GPL')
makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexif'
'libvorbis' 'mesa' 'libgl' 'mplayer' "mythtv>=${pkgver}"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
- 'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python2-pillow'
- 'python-pycurl' 'zlib')
+ 'perl-xml-simple' 'perl-xml-xpath' 'python2-oauth' 'python2-pillow'
+ 'python2-pycurl' 'zlib')
source=('mythburn.py-aspectratio.patch'
+ 'mythburn.cpp-python2.patch'
'cdparanoia.patch'
'0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch'
)
-build() {
+prepare() {
if [ -e ${srcdir}/mythplugins ]
then
msg "Removing old mythplugins src"
@@ -38,14 +39,21 @@ build() {
cd ${srcdir}
patch -Np1 -i "$srcdir/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch"
- msg "Patching configure"
+ msg "Change python to python2"
+ find . -name '*.py' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+ patch -Np1 -i "$srcdir/mythburn.cpp-python2.patch"
+
+ msg "Patching Configure"
cd ${srcdir}/${pkgbase}
patch -Np1 -i "$srcdir/cdparanoia.patch"
+}
+build() {
+ cd ${srcdir}/${pkgbase}
msg "Configuring mythplugins"
./configure --prefix=/usr \
--enable-all \
- --python=/usr/bin/python2
+ --python=python2
msg "Compiling mythplugins"
qmake-qt5 mythplugins.pro || return 1
@@ -93,7 +101,7 @@ package_mythmusic() {
package_mythnetvision() {
pkgdesc="MythNetvision plugin for MythTV"
- depends=("mythtv>=${pkgver}" 'python-pycurl' 'python-oauth'
+ depends=("mythtv>=${pkgver}" 'python2-pycurl' 'python2-oauth'
'python2-lxml' 'python2')
cd "${srcdir}/${_gitname}/${pkgbase}/mythnetvision"
make INSTALL_ROOT="${pkgdir}" install || return 1
@@ -124,5 +132,6 @@ package_mythzoneminder() {
}
md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2'
+ 'b9edd8f7da64ffa74baa91092bd48cc9'
'5de8dd79d0b8a2b006f3c3258938b6b7'
'0299d0214c0d3a452c0284352435d698')