summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-30/mythweb
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable-30/mythweb')
-rw-r--r--abs/core/mythtv/stable-30/mythweb/Channel.php_remove_small_icons.patch14
-rw-r--r--abs/core/mythtv/stable-30/mythweb/PKGBUILD60
-rw-r--r--abs/core/mythtv/stable-30/mythweb/mythweb.include8
-rw-r--r--abs/core/mythtv/stable-30/mythweb/mythweb.install22
-rw-r--r--abs/core/mythtv/stable-30/mythweb/mythweb_gen_light.conf1
-rw-r--r--abs/core/mythtv/stable-30/mythweb/video.css.patch98
6 files changed, 203 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable-30/mythweb/Channel.php_remove_small_icons.patch b/abs/core/mythtv/stable-30/mythweb/Channel.php_remove_small_icons.patch
new file mode 100644
index 0000000..f786d15
--- /dev/null
+++ b/abs/core/mythtv/stable-30/mythweb/Channel.php_remove_small_icons.patch
@@ -0,0 +1,14 @@
+diff --git a/modules/tv/classes/Channel.php b/modules/tv/classes/Channel.php
+index a4350283..be45b6ff 100644
+--- ./modules/tv/classes/Channel.php
++++ ./modules/tv/classes/Channel.php
+@@ -113,6 +113,9 @@ class Channel extends MythBase {
+ foreach ($channel_data AS $key => $value)
+ $this->$key = $value;
+ $this->icon = 'data/tv_icons/'.basename($channel_data['icon']);
++ // Remove icons smaller than 100 bytes
++ if (file_exists($this->icon) && filesize($this->icon) < 100)
++ unlink($this->icon);
+ // Try to copy over any missing channel icons
+ if ($channel_data['icon'] && !file_exists($this->icon)) {
+ // Local file?
diff --git a/abs/core/mythtv/stable-30/mythweb/PKGBUILD b/abs/core/mythtv/stable-30/mythweb/PKGBUILD
new file mode 100644
index 0000000..17e8c04
--- /dev/null
+++ b/abs/core/mythtv/stable-30/mythweb/PKGBUILD
@@ -0,0 +1,60 @@
+pkgname=mythweb
+pkgver=30.0
+pkgrel=1
+commit_hash=`cat ../git_src/git_hash_web`
+pkgdesc="Web interface for MythTV's backend, $commit_hash"
+arch=('x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=('lighttpd' "mythtv>=${pkgver}" 'php' 'supplemental-web')
+groups=('mythtv-extras')
+install=mythweb.install
+
+patches=('video.css.patch'
+ 'Channel.php_remove_small_icons.patch')
+source=(`echo ${patches[@]:0}`
+ 'mythweb.include'
+ 'mythweb_gen_light.conf')
+
+build() {
+ if [ -e ${srcdir}/mythweb ]
+ then
+ msg "Removing old mythweb src"
+ rm -rf ${srcdir}/mythweb
+ fi
+
+ cd ${startdir}
+ msg "Copying in mythweb git_src"
+ cp -rp ../git_src/mythweb $srcdir
+ cd ${srcdir}/$pkgname
+
+ msg "--------------------------applying patches------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${srcdir}/$i || return 1
+ done
+ msg "--------------------------done applying patches-------------------------"
+
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+}
+
+package() {
+ DOCROOT=/data/srv/httpd/mythweb
+ mkdir -p $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
+ rsync -arp --exclude .git* --delete-excluded $srcdir/mythweb/* $pkgdir/$DOCROOT
+ rm $pkgdir/$DOCROOT/README
+ chown -R http:http $pkgdir/$DOCROOT
+ chmod -R 775 $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
+
+ #install conf files for lighttpd
+ mkdir -p $pkgdir/etc/lighttpd
+ install -D -m 644 $srcdir/mythweb.include $pkgdir/etc/lighttpd/
+ #gen_light_conf
+ install -D -m0744 ${srcdir}/mythweb_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/mythweb.conf
+}
+md5sums=('668a36e404c8254f56e7a7304e655332'
+ '333d145899a1b48a7648d933344ee9ed'
+ '7645a6399434cbba35639713ac5d88e0'
+ 'df190116b3aba35720fb6631885f973f')
diff --git a/abs/core/mythtv/stable-30/mythweb/mythweb.include b/abs/core/mythtv/stable-30/mythweb/mythweb.include
new file mode 100644
index 0000000..18e9be1
--- /dev/null
+++ b/abs/core/mythtv/stable-30/mythweb/mythweb.include
@@ -0,0 +1,8 @@
+alias.url += ( "/mythweb" => "/data/srv/httpd/mythweb/")
+
+url.rewrite-once = (
+"^/{1,2}mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
+"^/{1,2}mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
+"^/{1,2}mythweb/(.+)$" => "/mythweb/mythweb.php/$1",
+"^/{1,2}mythweb/(.*)$" => "/mythweb/mythweb.php"
+) \ No newline at end of file
diff --git a/abs/core/mythtv/stable-30/mythweb/mythweb.install b/abs/core/mythtv/stable-30/mythweb/mythweb.install
new file mode 100644
index 0000000..b8e31a8
--- /dev/null
+++ b/abs/core/mythtv/stable-30/mythweb/mythweb.install
@@ -0,0 +1,22 @@
+post_install() {
+ echo "==> Setting mythweb permissions."
+ chmod -R 755 /data/srv/httpd/mythweb/
+ chown mythtv:http /data/srv/httpd/mythweb/data/tv_icons
+ chmod -R 775 /data/srv/httpd/mythweb/{image_cache,php_sessions,data}
+ echo "==> Reading lighttpd's configuration file."
+ gen_light_include.py
+ echo "==> Restarting lighttpd."
+ /sbin/sv hup /service/lighttpd
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gen_light_include.py
+ echo
+ echo "==> Forcing a re-read of lighttpd's configuration file."
+ echo ""
+ /sbin/sv hup /service/lighttpd
+}
diff --git a/abs/core/mythtv/stable-30/mythweb/mythweb_gen_light.conf b/abs/core/mythtv/stable-30/mythweb/mythweb_gen_light.conf
new file mode 100644
index 0000000..ddf0d2f
--- /dev/null
+++ b/abs/core/mythtv/stable-30/mythweb/mythweb_gen_light.conf
@@ -0,0 +1 @@
+include "/etc/lighttpd/mythweb.include"
diff --git a/abs/core/mythtv/stable-30/mythweb/video.css.patch b/abs/core/mythtv/stable-30/mythweb/video.css.patch
new file mode 100644
index 0000000..f49a3fd
--- /dev/null
+++ b/abs/core/mythtv/stable-30/mythweb/video.css.patch
@@ -0,0 +1,98 @@
+--- ./skins/default/video.css.orig 2018-05-22 21:45:30.395508513 +0000
++++ ./skins/default/video.css 2018-05-22 21:41:27.326893228 +0000
+@@ -0,0 +1,95 @@
++ .video {
++ position: relative;
++ padding: 1em;
++ float: left;
++ background-color: #003366;
++ margin-top: 1em;
++ margin-left: 1em;
++ width: 202px;
++ height: 168px;
++ border: 1px solid black;
++ }
++
++ .video .title {
++ font-weight: bold;
++ margin-bottom: .5em;
++ height: 2.5em;
++ overflow: hidden;
++ }
++
++ .video img {
++ float: left;
++ padding-right: 1em;
++ }
++
++ .video .command {
++ position: absolute;
++ bottom: 1em;
++ right: 1em;
++ }
++
++ #path {
++ position: relative;
++ padding: 1em;
++ float: left;
++ background-color: #102923;
++ margin-top: 1em;
++ margin-left: 1em;
++ border: 1px solid black;
++ min-width: 202px;
++ min-height: 168px;
++ }
++
++ #path .active {
++ color: yellow;
++ }
++
++ #window {
++ position: fixed;
++ left: 35%;
++ right: 35%;
++ width: 30%;
++ top: 35%;
++ background-color: green;
++ padding-top: 1em;
++ z-index: 10;
++ border: 2px solid gray;
++ }
++
++ #window_content a {
++ padding-right: 1em;
++ padding-left: 1em;
++ }
++
++ #window iframe {
++ width: 100%;
++ border: 0px;
++ height: 250px;
++ }
++
++ #window_title {
++ position: absolute;
++ top: 1px;
++ left: 1em;
++ font-weight: bold;
++ }
++
++ .popup {
++ width: 30%;
++ font-size: 9pt;
++ }
++
++ .popup dt {
++ clear: left;
++ float: left;
++ padding-top: 3px;
++ white-space: nowrap;
++ width: 6em;
++ font-weight: bold;
++ text-align: right;
++ }
++
++ .popup dd {
++ margin-left: 6.5em;
++ padding-top: 3px;
++ }