summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable/mythflix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable/mythflix/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable/mythflix/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable/mythflix/PKGBUILD b/abs/core/mythtv/stable/mythflix/PKGBUILD
new file mode 100644
index 0000000..f613963
--- /dev/null
+++ b/abs/core/mythtv/stable/mythflix/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Maintainer: kleptophobiac@gmail.com
+
+pkgname=mythflix
+pkgver=0.21
+pkgrel=1
+pkgdesc="Netflix access plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}")
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('af20a78ac66719feddf9a39f1a799ded')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins-${pkgver}
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ ./configure --prefix=/usr --disable-all --enable-opengl --enable-mythflix
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+