summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable/mythflix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable/mythflix/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable/mythflix/PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/abs/core/mythtv/stable/mythflix/PKGBUILD b/abs/core/mythtv/stable/mythflix/PKGBUILD
index f613963..5423c06 100644
--- a/abs/core/mythtv/stable/mythflix/PKGBUILD
+++ b/abs/core/mythtv/stable/mythflix/PKGBUILD
@@ -3,28 +3,38 @@
# Maintainer: kleptophobiac@gmail.com
pkgname=mythflix
+PLUGIN=$pkgname
pkgver=0.21
-pkgrel=1
+pkgrel=5
pkgdesc="Netflix access plugin for MythTV"
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
depends=("mythtv>=${pkgver}")
source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
-md5sums=('af20a78ac66719feddf9a39f1a799ded')
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
groups=('mythtv-extras')
build() {
- cd $startdir/src/mythplugins-${pkgver}
+ cd $startdir/src/mythplugins
. /etc/profile.d/qt3.sh
-
- # use QT3 qmake
+ svn update
+ cd $startdir/src/mythplugins
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ cd -
+ # use QT3 qmake
export PATH=$QTDIR/bin:$PATH
./configure --prefix=/usr --disable-all --enable-opengl --enable-mythflix
qmake mythplugins.pro
make qmake || return 1
- make -j 2 || return 1
+# make -j 2 || return 1
+ make || return 1
make INSTALL_ROOT=$startdir/pkg install
}