summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable/mythweather/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable/mythweather/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable/mythweather/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable/mythweather/PKGBUILD b/abs/core/mythtv/stable/mythweather/PKGBUILD
new file mode 100644
index 0000000..ce2894a
--- /dev/null
+++ b/abs/core/mythtv/stable/mythweather/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythweather
+pkgver=0.21
+pkgrel=1
+pkgdesc="Weather checking plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'wget')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('af20a78ac66719feddf9a39f1a799ded')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins-${pkgver}
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+
+ ./configure --prefix=/usr --enable-opengl --disable-all --enable-mythweather
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+