summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable/mythweb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable/mythweb/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable/mythweb/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable/mythweb/PKGBUILD b/abs/core/mythtv/stable/mythweb/PKGBUILD
new file mode 100644
index 0000000..e01323c
--- /dev/null
+++ b/abs/core/mythtv/stable/mythweb/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Philipp Giebel <arch@ambience-design.net>
+
+pkgname=mythweb
+pkgver=0.21
+pkgrel=1
+pkgdesc="Web interface for MythTV's backend"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'apache' 'php')
+install=mythweb.install
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('af20a78ac66719feddf9a39f1a799ded')
+groups=('mythtv-extras')
+
+build() {
+ mkdir -p $startdir/pkg/srv/www/mythweb/{image_cache,php_sessions}
+ cp -r $startdir/src/mythplugins-$pkgver/$pkgname/* $startdir/pkg/srv/www/mythweb
+ cp $startdir/src/mythplugins-$pkgver/$pkgname/data/.htaccess $startdir/pkg/srv/www/mythweb
+ rm $startdir/pkg/srv/www/mythweb/README
+ chown -R nobody:nobody $startdir/pkg/srv/www/mythweb
+ chmod g+rw $startdir/pkg/srv/www/mythweb/{image_cache,php_sessions,data}
+}
+
+