summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/trunk/mythweather/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/trunk/mythweather/PKGBUILD')
-rw-r--r--abs/core/mythtv/trunk/mythweather/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/abs/core/mythtv/trunk/mythweather/PKGBUILD b/abs/core/mythtv/trunk/mythweather/PKGBUILD
new file mode 100644
index 0000000..0655236
--- /dev/null
+++ b/abs/core/mythtv/trunk/mythweather/PKGBUILD
@@ -0,0 +1,50 @@
+pkgname=mythweather-svn
+pkgver=21495
+pkgrel=1
+pkgdesc="Weather checking plugin for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'wget')
+conflicts=('mythweather')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn revert -R $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # clean up
+ make distclean
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythweather || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}