summaryrefslogtreecommitdiffstats
path: root/abs/core/ncurses/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ncurses/PKGBUILD')
-rw-r--r--abs/core/ncurses/PKGBUILD104
1 files changed, 46 insertions, 58 deletions
diff --git a/abs/core/ncurses/PKGBUILD b/abs/core/ncurses/PKGBUILD
index 052881e..c0fd425 100644
--- a/abs/core/ncurses/PKGBUILD
+++ b/abs/core/ncurses/PKGBUILD
@@ -1,75 +1,63 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 19129 2008-11-15 00:00:47Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
pkgname=ncurses
-pkgver=5.6
-pkgrel=15
-pkgdesc="A System V Release 4.0 curses emulation library"
-arch=(i686 x86_64)
-url="http://www.gnu.org/software/ncurses/ncurses.html"
+pkgver=5.7
+pkgrel=2
+pkgdesc="System V Release 4.0 curses emulation library"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/ncurses/"
license=('MIT')
groups=('base')
depends=('glibc')
-source=(ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('b6593abe1089d6aab1551c105c9300e3')
-options=(!makeflags)
+source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('cce05daf61a64501ef6cd8da1f727ec6')
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd ${srcdir}/${pkgname}-${pkgver}
- # The chtype/mmask-t settings below are to retain ABI compat
- # with ncurses-5.4 so dont change em !
- # we should test in next update if we can drop it.
-if [ "$CARCH" == "x86_64" ]; then
- ./configure --prefix=/usr \
+ ./configure --prefix=/usr --mandir=/usr/share/man \
--with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=$startdir/pkg \
- --with-chtype='long' --with-mmask-t='long'
- else
- ./configure --prefix=/usr \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=$startdir/pkg
-fi
+ --with-install-prefix=${pkgdir} --enable-widec
make || return 1
make install
- mkdir -p $startdir/pkg/lib
- cd $startdir/pkg/usr/lib
- mv libncurses.so.$pkgver ../../lib
- ln -sf ../../lib/libncurses.so.$pkgver libncurses.so.$pkgver
- cd $startdir/pkg/lib
- ln -sf libncurses.so.$pkgver libncurses.so.5
- rm -f $startdir/pkg/lib/libcurses.so
- # build unicode support libs
- cd $startdir/src/$pkgname-$pkgver
- make clean
-if [ "$CARCH" == "x86_64" ]; then
- ./configure --prefix=/usr \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=$startdir/pkg --enable-widec \
- --with-chtype='long' --with-mmask-t='long'
- else
+ # move libraries needed for boot to /lib (we call tput in initscripts)
+ install -dm755 ${pkgdir}/lib
+ mv ${pkgdir}/usr/lib/libncursesw.so.5* ${pkgdir}/lib
+ ln -sf ../../lib/libncursesw.so.5 ${pkgdir}/usr/lib/libncursesw.so
+
+ # Fool packages looking to link to non-wide-character ncurses libraries
+ for lib in curses ncurses form panel menu ; do \
+ rm -f ${pkgdir}/usr/lib/lib${lib}.so ; \
+ echo "INPUT(-l${lib}w)" >${pkgdir}/usr/lib/lib${lib}.so ; \
+ ln -sf lib${lib}w.a ${pkgdir}/usr/lib/lib${lib}.a ; \
+ done
+ ln -sf libncurses++w.a ${pkgdir}/usr/lib/libncurses++.a
+
+ # install tput to /bin
+ install -dm755 ${pkgdir}/bin/
+ mv ${pkgdir}/usr/bin/tput ${pkgdir}/bin/tput
+
+ # Some packages look for -lcurses during build
+ rm -f ${pkgdir}/usr/lib/libcursesw.so
+ echo "INPUT(-lncursesw)" >${pkgdir}/usr/lib/libcursesw.so
+ ln -sf libncurses.so ${pkgdir}/usr/lib/libcurses.so
+ ln -sf libncursesw.a ${pkgdir}/usr/lib/libcursesw.a
+ ln -sf libncurses.a ${pkgdir}/usr/lib/libcurses.a
+
+ # Install libncurses.so.5 for external binary support
./configure --prefix=/usr \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=$startdir/pkg --enable-widec
-fi
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=${pkgdir}
make || return 1
- make install
- mkdir $startdir/pkg/usr/include/ncursesw
- ln -sf /usr/include/ncurses.h $startdir/pkg/usr/include/ncursesw
- # fix library for tput, we call it in initscripts!
- cd $startdir/pkg/usr/lib
- mv libncursesw.so.$pkgver ../../lib
- ln -sf ../../lib/libncursesw.so.$pkgver libncursesw.so.$pkgver
- cd $startdir/pkg/lib
- ln -sf libncursesw.so.$pkgver libncursesw.so.5
-
- # install tput to /bin
- mkdir $startdir/pkg/bin/
- mv $startdir/pkg/usr/bin/tput $startdir/pkg/bin/tput
+ install -Dm755 lib/libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.${pkgver}
+ ln -sf libncurses.so.${pkgver} ${pkgdir}/usr/lib/libncurses.so.5
# install license, rip it from the readme
- cd $startdir/src/$pkgname-$pkgver
- mkdir -p $startdir/pkg/usr/share/licenses/$pkgname
- grep -B 100 '$Id' README > $startdir/pkg/usr/share/licenses/$pkgname/license.txt
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -dm755 ${pkgdir}/usr/share/licenses/$pkgname
+ grep -B 100 '$Id' README > ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
}