summaryrefslogtreecommitdiffstats
path: root/abs/core/nettle/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/nettle/PKGBUILD')
-rw-r--r--abs/core/nettle/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core/nettle/PKGBUILD b/abs/core/nettle/PKGBUILD
new file mode 100644
index 0000000..2e9f8c0
--- /dev/null
+++ b/abs/core/nettle/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 163476 2012-07-12 19:05:48Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: bender02 at gmx dot com
+
+pkgname=nettle
+pkgver=2.5
+pkgrel=1
+pkgdesc="A low-level cryptographic library"
+arch=('i686' 'x86_64')
+url="http://www.lysator.liu.se/~nisse/nettle/"
+license=('GPL2')
+install=$pkgname.install
+depends=('gmp')
+source=(ftp://ftp.lysator.liu.se/pub/security/lsh/$pkgname-$pkgver.tar.gz)
+md5sums=('d66882e6ad31a9f651b73d7a1a93bd4c')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --libdir=/usr/lib \
+ --enable-shared \
+ --disable-static # <-- seems not working now
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # remove static libs
+ rm -f ${pkgdir}/usr/lib/{libhogweed,libnettle}.a
+}