summaryrefslogtreecommitdiffstats
path: root/abs/core/nilfs-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/nilfs-utils/PKGBUILD')
-rw-r--r--abs/core/nilfs-utils/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/nilfs-utils/PKGBUILD b/abs/core/nilfs-utils/PKGBUILD
new file mode 100644
index 0000000..f943a0d
--- /dev/null
+++ b/abs/core/nilfs-utils/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 163896 2012-07-21 19:19:52Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+
+pkgname=nilfs-utils
+pkgver=2.1.4
+pkgrel=1
+pkgdesc="A log-structured file system supporting continuous snapshotting (userspace utils)"
+arch=('i686' 'x86_64')
+url="http://www.nilfs.org/"
+license=('GPL2' 'LGPL2.1')
+backup=('etc/nilfs_cleanerd.conf')
+depends=('util-linux')
+options=(!libtool)
+source=(http://www.nilfs.org/download/$pkgname-$pkgver.tar.bz2)
+md5sums=('e72f941f5041a057a81a1ce22e03497d')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --enable-libmount
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install LDCONFIG=/bin/true
+}