summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-304xx/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/nvidia-304xx/PKGBUILD')
-rw-r--r--abs/core/nvidia-304xx/PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/abs/core/nvidia-304xx/PKGBUILD b/abs/core/nvidia-304xx/PKGBUILD
index 9456106..a8eaf80 100644
--- a/abs/core/nvidia-304xx/PKGBUILD
+++ b/abs/core/nvidia-304xx/PKGBUILD
@@ -4,21 +4,25 @@
pkgbase=nvidia-304xx
pkgname=(nvidia-304xx nvidia-304xx-dkms)
-pkgver=304.134
+pkgver=304.135
_extramodules=extramodules-4.4-ARCH
-pkgrel=1
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-makedepends=('nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}" 'linux' 'linux-headers>=4.4' 'linux-headers<4.5')
+makedepends=('linux' 'linux-headers>=4.4' 'linux-headers<4.5')
conflicts=('nvidia')
license=('custom')
options=('!strip')
-source=('disable-mtrr.patch')
+source=('disable-mtrr.patch'
+ 'drm-driver-legacy.patch'
+ 'kernel_4.10.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha512sums=('54e8825e523f11706890e09e476498f3a30f75ce4e350ff2ff8a1e1c3af574d9ccfb8903543766b6863d94cdfbf46e68cd3d33380867dd976cafc8dd2dd78774')
-sha512sums_i686=('e047c62b33b092225ead42134acd596e3ae43d9bb8324188308dd7d497f33e790e7366d7a1c5ef5de66f484219d99de4c6e6206d390122d3fab4d30397ab463c')
-sha512sums_x86_64=('339efb8b47faaa16b984d84e43ef18d849a563c95298972c36616a22712740e3233c2cd7b0837d393a8f24a6ec5b501295cdc77adae12deccc993dfca48022fc')
+sha512sums=('54e8825e523f11706890e09e476498f3a30f75ce4e350ff2ff8a1e1c3af574d9ccfb8903543766b6863d94cdfbf46e68cd3d33380867dd976cafc8dd2dd78774'
+ 'fa39dee5c9f1ea98286c87165f683ee194b2cb4056aa6b556e822b9ee760dcf3683ea001c3704e79b9ac9712314d7df5690dc7f68440cda7a96791f94425455d'
+ '68dabbf6ad889c46bd0c01ebb697b80f4aa526ef1cdc53de008343a243adefc6ce7f2778be7005f2d79f3d23c0a3ff69f67ecdb9f97c0feb0ec99405a0c1046a')
+sha512sums_i686=('c2645cc9a6f23641d8b6da51e72e203980068c05e365fcc73b32322a6875ce95e81f4e0d893276e14e84e93464488539c16db6b3be04f5324cf7d7a12bb557f8')
+sha512sums_x86_64=('a5aa48baa75eb267bd193e59328aa5fbc15d41045bb7e97aa1b96b918b9e68a1c1bf95624d9d494336256e0af2c41e188d30fe91be4967084de3387f50d3805c')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -28,9 +32,11 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
+# patch -Np1 --no-backup-if-mismatch -i ../kernel_4.10.patch
# FS#47092
- (cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
+ #(cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
+ (cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/drm-driver-legacy.patch)
cp -a kernel kernel-dkms
}