summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-96xx
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/nvidia-96xx')
-rw-r--r--abs/core/nvidia-96xx/NVIDIA_173.14.12_2.6.27.patch87
-rw-r--r--abs/core/nvidia-96xx/PKGBUILD9
-rw-r--r--abs/core/nvidia-96xx/nvidia-96xx.install22
-rw-r--r--abs/core/nvidia-96xx/nvidia.install4
4 files changed, 7 insertions, 115 deletions
diff --git a/abs/core/nvidia-96xx/NVIDIA_173.14.12_2.6.27.patch b/abs/core/nvidia-96xx/NVIDIA_173.14.12_2.6.27.patch
deleted file mode 100644
index 1ba936b..0000000
--- a/abs/core/nvidia-96xx/NVIDIA_173.14.12_2.6.27.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff -Nru NVIDIA-Linux-x86-173.14.12-pkg0.orig/usr/src/nv/nv.c NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv.c
---- usr/src/nv/nv.c 2008-07-18 03:42:50.000000000 +0200
-+++ NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv.c 2008-08-12 00:35:45.000000000 +0200
-@@ -1296,14 +1296,22 @@
- if (get_cpu() == cpu)
- __nv_setup_pat_entries(NULL);
- else
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
-+ smp_call_function(__nv_setup_pat_entries, hcpu, 1);
-+ #else
- smp_call_function(__nv_setup_pat_entries, hcpu, 1, 1);
-+ #endif
- put_cpu();
- break;
- case CPU_DOWN_PREPARE:
- if (get_cpu() == cpu)
- __nv_restore_pat_entries(NULL);
- else
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
-+ smp_call_function(__nv_restore_pat_entries, hcpu, 1);
-+ #else
- smp_call_function(__nv_restore_pat_entries, hcpu, 1, 1);
-+ #endif
- put_cpu();
- break;
- }
-diff -Nru NVIDIA-Linux-x86-173.14.12-pkg0.orig/usr/src/nv/nv-linux.h NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv-linux.h
---- usr/src/nv/nv-linux.h 2008-07-18 03:42:51.000000000 +0200
-+++ NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv-linux.h 2008-08-12 00:44:27.000000000 +0200
-@@ -104,7 +104,10 @@
- #endif
-
- #include <linux/spinlock.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
-+#else
- #include <asm/semaphore.h>
-+#endif
- #include <linux/completion.h>
- #include <linux/highmem.h>
-
-@@ -665,13 +668,21 @@
- #if defined(preempt_disable)
- preempt_disable();
- #endif
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
-+ ret = smp_call_function(func, info, 1);
-+ #else
- ret = smp_call_function(func, info, 1, 1);
-+ #endif
- func(info);
- #if defined(preempt_enable)
- preempt_enable();
- #endif
- #else
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
-+ ret = on_each_cpu(func, info, 1);
-+ #else
- ret = on_each_cpu(func, info, 1, 1);
-+ #endif
- #endif
- return ret;
- }
-diff -Nru NVIDIA-Linux-x86-173.14.12-pkg0.orig/usr/src/nv/os-interface.c NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/os-interface.c
---- usr/src/nv/os-interface.c 2008-07-18 03:42:50.000000000 +0200
-+++ NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/os-interface.c 2008-08-12 00:48:07.000000000 +0200
-@@ -48,7 +48,11 @@
- #endif
- local_bh_disable();
- atomic_set(&os_smp_barrier, 1);
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
-+ ret = smp_call_function(ipi_handler, NULL, 0);
-+ #else
- ret = smp_call_function(ipi_handler, NULL, 1, 0);
-+ #endif
- #endif
- return (ret == 0) ? RM_OK : RM_ERROR;
- }
-@@ -704,7 +708,9 @@
- U032 sig
- )
- {
-+ #if LINUX_VERSION_CODE <= KERNEL_VERSION(2, 6, 26)
- return kill_proc(pid, sig, 1) ? RM_ERR_OPERATING_SYSTEM : RM_OK;
-+ #endif
- }
-
- /*******************************************************************************/
diff --git a/abs/core/nvidia-96xx/PKGBUILD b/abs/core/nvidia-96xx/PKGBUILD
index df89e5f..78cd2ca 100644
--- a/abs/core/nvidia-96xx/PKGBUILD
+++ b/abs/core/nvidia-96xx/PKGBUILD
@@ -3,16 +3,17 @@
pkgname=nvidia-96xx
pkgver=96.43.16
-_kernver='2.6.28-LinHES'
+_kernver='2.6.34-LinHES'
-pkgrel=1
+pkgrel=2
pkgdesc="NVIDIA drivers for kernel26, 96xx branch."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
url="http://www.nvidia.com/"
-depends=('kernel26>=2.6.28' 'kernel26<2.6.29' 'nvidia-96xx-utils')
-makedepends=('kernel-headers>=2.6.28' 'kernel-headers<2.6.29')
+#depends=('kernel26>=2.6.28' 'kernel26<2.6.29' 'nvidia-96xx-utils')
+depends=('kernel26' 'nvidia-96xx-utils')
+makedepends=('kernel-headers')
conflicts=('nvidia' 'nvidia-173xx')
license=('custom')
install=nvidia.install
diff --git a/abs/core/nvidia-96xx/nvidia-96xx.install b/abs/core/nvidia-96xx/nvidia-96xx.install
deleted file mode 100644
index 23e04af..0000000
--- a/abs/core/nvidia-96xx/nvidia-96xx.install
+++ /dev/null
@@ -1,22 +0,0 @@
-# arg 1: the new package version
-post_install() {
- KERNEL_VERSION='2.6.28-LinHES'
- depmod -v $KERNEL_VERSION > /dev/null 2>&1
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install $1
- rmmod nvidia || echo 'In order to use the new nvidia module, exit Xserver and unload it manually.'
-}
-
-# arg 1: the old package version
-post_remove() {
- KERNEL_VERSION='2.6.28-LinHES'
- depmod -v $KERNEL_VERSION > /dev/null 2>&1
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/core/nvidia-96xx/nvidia.install b/abs/core/nvidia-96xx/nvidia.install
index ab86ea2..a7e09f9 100644
--- a/abs/core/nvidia-96xx/nvidia.install
+++ b/abs/core/nvidia-96xx/nvidia.install
@@ -1,5 +1,5 @@
post_install() {
- KERNEL_VERSION='2.6.28-LinHES'
+ KERNEL_VERSION='2.6.34-LinHES'
depmod $KERNEL_VERSION
}
@@ -9,6 +9,6 @@ post_upgrade() {
}
post_remove() {
- KERNEL_VERSION='2.6.28-LinHES'
+ KERNEL_VERSION='2.6.34-LinHES'
depmod $KERNEL_VERSION
}