summaryrefslogtreecommitdiffstats
path: root/abs/core/p11-kit/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/p11-kit/PKGBUILD')
-rw-r--r--abs/core/p11-kit/PKGBUILD25
1 files changed, 21 insertions, 4 deletions
diff --git a/abs/core/p11-kit/PKGBUILD b/abs/core/p11-kit/PKGBUILD
index 6c74929..a0d282b 100644
--- a/abs/core/p11-kit/PKGBUILD
+++ b/abs/core/p11-kit/PKGBUILD
@@ -2,16 +2,31 @@
# Maintainer: Ionut Biru <ibiru@archlinux.org>
pkgname=p11-kit
-pkgver=0.20.7
+pkgver=0.23.1
pkgrel=2
pkgdesc="Library to work with PKCS#11 modules"
arch=(i686 x86_64)
url="http://p11-glue.freedesktop.org"
license=('BSD')
depends=('glibc' 'libtasn1' 'libffi')
-source=($url/releases/$pkgname-$pkgver.tar.gz{,.sig})
-md5sums=('6648cad01a3080b685b8b3bf7372c91a'
- 'SKIP')
+source=($url/releases/$pkgname-$pkgver.tar.gz{,.sig}
+ libnssckbi-compat.patch)
+md5sums=('96f073270c489c9a594e1c9413f42db8'
+ 'SKIP'
+ '8c3f119005908cf4a3e0ef0a0a310f14')
+validpgpkeys=('C0F67099B808FB063E2C81117BFB1108D92765AF')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Build and install an additional library (libnssckbi-p11-kit.so) which
+ # is a copy of p11-kit-trust.so but uses the same label for root certs as
+ # libnssckbi.so ("Builtin Object Token" instead of "Default Trust")
+ # https://bugs.freedesktop.org/show_bug.cgi?id=66161
+ patch -Np1 -i ../libnssckbi-compat.patch
+
+ autoreconf -vi
+}
build() {
cd $pkgname-$pkgver
@@ -30,6 +45,8 @@ package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+
+ ln -srf "$pkgdir/usr/bin/update-ca-trust" "$pkgdir/usr/lib/p11-kit/trust-extract-compat"
}
# vim:set ts=2 sw=2 et: