summaryrefslogtreecommitdiffstats
path: root/abs/core/parted/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/parted/PKGBUILD')
-rw-r--r--abs/core/parted/PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/abs/core/parted/PKGBUILD b/abs/core/parted/PKGBUILD
index be2d735..d166fd8 100644
--- a/abs/core/parted/PKGBUILD
+++ b/abs/core/parted/PKGBUILD
@@ -1,24 +1,31 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Contributor: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 82289 2010-06-10 01:52:54Z andrea $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=parted
-pkgver=1.8.8
-pkgrel=2
+pkgver=2.3
+pkgrel=1
pkgdesc="A program for creating, destroying, resizing, checking and copying partitions"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL3')
url="http://www.gnu.org/software/parted/parted.html"
-depends=('e2fsprogs')
-source=(ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz parted-1.7.1-fix-seg.patch)
-md5sums=('0d494591731082ec57cc18627728124a' '88f3c5b45fdd1d3dce70a1a19bf48481')
-options=(!libtool !emptydirs)
+depends=('device-mapper' 'e2fsprogs')
+options=('!libtool')
+install=${pkgname}.install
+source=("http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('30ceb6df7e8681891e865e2fe5a7903d')
build() {
- cd $startdir/src/$pkgname-$pkgver
- #Arch64 fix - still needed?
- [ "$CARCH" = "x86_64" ] && patch -Np1 -i ../parted-1.7.1-fix-seg.patch
- ./configure --prefix=/usr --disable-debug --disable-Werror
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --disable-debug \
+ --disable-rpath \
+ --disable-Werror || return 1
make || return 1
- make DESTDIR=$startdir/pkg install
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
}