summaryrefslogtreecommitdiffstats
path: root/abs/core/pcre2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pcre2/PKGBUILD')
-rw-r--r--abs/core/pcre2/PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/abs/core/pcre2/PKGBUILD b/abs/core/pcre2/PKGBUILD
new file mode 100644
index 0000000..9c2e463
--- /dev/null
+++ b/abs/core/pcre2/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Mateusz 'mrlemux' Lemusisk mrlemux at gmail dotcom
+# Based on the pcre package by Sébastien "Seblu" Luttringer
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+
+pkgname=pcre2
+pkgver=10.30
+pkgrel=1
+pkgdesc='A library that implements Perl 5-style regular expressions. 2nd version'
+arch=('x86_64')
+url='http://www.pcre.org/'
+license=('BSD')
+depends=('gcc-libs' 'readline' 'zlib' 'bzip2' 'bash')
+source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/$pkgname-$pkgver.tar.bz2")
+sha512sums=('f247a9f917c75920793b9919a45bb1426d126246e7a5d04e39d9407e44b5781f894a90cd3d232b385436b2f22be391335ab782664dd3a28c79058a2fcc74dc3e')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --enable-pcre2-16 \
+ --enable-pcre2-32 \
+ --enable-jit \
+ --enable-pcre2grep-libz \
+ --enable-pcre2grep-libbz2 \
+ --enable-pcre2test-libreadline
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make -j1 check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: