summaryrefslogtreecommitdiffstats
path: root/abs/core/perl-exception-class/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl-exception-class/PKGBUILD')
-rw-r--r--abs/core/perl-exception-class/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/core/perl-exception-class/PKGBUILD b/abs/core/perl-exception-class/PKGBUILD
new file mode 100644
index 0000000..91528e7
--- /dev/null
+++ b/abs/core/perl-exception-class/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
+
+pkgname=perl-exception-class
+pkgver=1.44
+pkgrel=1
+pkgdesc='A module that allows you to declare real exception classes in Perl'
+arch=('any')
+url="https://metacpan.org/release/Exception-Class"
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.8.1' 'perl-class-data-inheritable>=0.02' 'perl-devel-stacktrace>=2.00')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Exception-Class-$pkgver.tar.gz)
+sha256sums=('33f3fbf8b138d3b04ea4ec0ba83fb0df6ba898806bcf4ef393d4cafc1a23ee0d')
+
+build() {
+ cd "${srcdir}"/Exception-Class-$pkgver
+
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ unset PERL5LIB PERL_MM_OPT
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${srcdir}"/Exception-Class-$pkgver
+
+ export PERL_MM_USE_DEFAULT=1
+ unset PERL5LIB
+ make test
+}
+
+package() {
+ cd "${srcdir}"/Exception-Class-$pkgver
+
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+
+ find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
+}