summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-alien-sdl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-alien-sdl/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-alien-sdl/PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/abs/core/perl_modules/perl-alien-sdl/PKGBUILD b/abs/core/perl_modules/perl-alien-sdl/PKGBUILD
index 4b6bded..9e76ddf 100644
--- a/abs/core/perl_modules/perl-alien-sdl/PKGBUILD
+++ b/abs/core/perl_modules/perl-alien-sdl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 165868 2012-09-01 20:47:49Z heftig $
+# $Id$
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
@@ -8,25 +8,35 @@
pkgname=perl-alien-sdl
_realname=Alien-SDL
-pkgver=1.438
-pkgrel=1
+pkgver=1.446
+pkgrel=4
pkgdesc="Building, finding and using SDL binaries"
-arch=(i686 x86_64)
+arch=(x86_64)
license=(PerlArtistic GPL)
url="http://search.cpan.org/dist/Alien-SDL/"
-depends=(sdl=1.2.15 perl-file-sharedir perl-capture-tiny)
-makedepends=(perl-file-which perl-text-patch)
+depends=('sdl=1.2.15' perl-file-sharedir perl-capture-tiny)
+makedepends=(perl-file-which perl-text-patch perl-archive-extract perl-archive-zip perl-module-build)
options=(!emptydirs)
-_author=JTPALMER
+_author=FROGGS
source=(http://search.cpan.org/CPAN/authors/id/${_author::1}/${_author::2}/$_author/$_realname-$pkgver.tar.gz)
-md5sums=('1936ba9e300677151124b62883cedf20')
+sha256sums=('c9aa2c9dc3c63d89773c7d7203f2a46d1b924d0c72d9f801af147a3dc8bc512a')
-package() {
- cd "$srcdir/$_realname-$pkgver"
+prepare() {
+ cd $_realname-$pkgver
- # install module in vendor directories
- perl Build.PL installdirs=vendor destdir="$pkgdir" --with-sdl-config
+ # Workaround bug with --with-sdl-config
+ sed -i '/^GetOptions/d' Build.PL
+}
+
+build() {
+ cd $_realname-$pkgver
+ # install module in vendor directories
+ perl Build.PL --with-sdl-config
perl Build
- perl Build install
+}
+
+package() {
+ cd $_realname-$pkgver
+ perl Build install installdirs=vendor destdir="$pkgdir"
}