summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-astro-suntime/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-astro-suntime/PKGBUILD64
1 files changed, 42 insertions, 22 deletions
diff --git a/abs/core/perl_modules/perl-astro-suntime/PKGBUILD b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
index d615aa3..7fe6143 100644
--- a/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
+++ b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
@@ -1,29 +1,49 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
-# Contributor: Ross melin <rdmelin@gmail.com>
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
-# Required by zoneminder
-
-pkgname=perl-astro-suntime
-pkgver=0.01
-pkgrel=2
-pkgdesc="Calculate sun rise/set times"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~ROBF/Astro-SunTime"
-license=('GPL' 'PerlArtistic')
-depends=('perl-time-modules')
+pkgname='perl-astro-suntime'
+pkgver='0.06'
+pkgrel='1'
+pkgdesc="Get Sun Rise and Set Times for any location on the globe"
+arch=('any')
+license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz)
-md5sums=('4657927a49604494bfaaa153663b90b9')
+depends=('perl-time-modules')
+makedepends=()
+url='https://metacpan.org/release/Astro-SunTime'
+source=("http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz")
+_distdir="Astro-SunTime-$pkgver"
build() {
- cd $startdir/src/Astro-SunTime-$pkgver
- eval `perl -V:archname`
- PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
- INSTALLDIRS=vendor || return 1
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install || return 1
- /usr/bin/find $startdir/pkg -name '.packlist' -delete
- /usr/bin/find $startdir/pkg -name '*.pod' -delete
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et:
+md5sums=('42cb8c94de8a111ed652196925c22a45')