summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-astro-suntime/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-astro-suntime/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-astro-suntime/PKGBUILD b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
new file mode 100644
index 0000000..d615aa3
--- /dev/null
+++ b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-astro-suntime
+pkgver=0.01
+pkgrel=2
+pkgdesc="Calculate sun rise/set times"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~ROBF/Astro-SunTime"
+license=('GPL' 'PerlArtistic')
+depends=('perl-time-modules')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz)
+md5sums=('4657927a49604494bfaaa153663b90b9')
+
+build() {
+ cd $startdir/src/Astro-SunTime-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: