summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-capture-tiny/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-capture-tiny/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/abs/core/perl_modules/perl-capture-tiny/PKGBUILD b/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
index a0987b3..4b15057 100644
--- a/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
+++ b/abs/core/perl_modules/perl-capture-tiny/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 167936 2012-10-03 22:20:09Z heftig $
+# $Id$
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Caleb Cushing <xenoterracide@gmail.com>
pkgname=perl-capture-tiny
_realname=Capture-Tiny
-pkgver=0.20
-pkgrel=1
+pkgver=0.46
+pkgrel=3
pkgdesc="Capture STDOUT and STDERR from Perl, XS or external programs"
arch=(any)
license=(PerlArtistic GPL)
@@ -13,7 +13,7 @@ depends=(perl)
url="http://search.cpan.org/dist/Capture-Tiny"
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/$_realname-$pkgver.tar.gz")
-md5sums=('cd7aab9f3bccefc76c7d4f0455c55d35')
+sha256sums=('5d7a6a830cf7f2b2960bf8b8afaac16a537ede64f3023827acea5bd24ca77015')
build() {
cd "$srcdir/$_realname-$pkgver"
@@ -21,6 +21,13 @@ build() {
make
}
+check() {
+ cd "$srcdir/$_realname-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
package() {
cd "$srcdir/$_realname-$pkgver"
make DESTDIR="$pkgdir" install