summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-class-inspector/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-class-inspector/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-class-inspector/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-class-inspector/PKGBUILD b/abs/core/perl_modules/perl-class-inspector/PKGBUILD
new file mode 100644
index 0000000..ca24226
--- /dev/null
+++ b/abs/core/perl_modules/perl-class-inspector/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer:
+
+pkgname=perl-class-inspector
+pkgver=1.32
+pkgrel=3
+pkgdesc="Get information about a class and its structure"
+arch=('any')
+url="http://search.cpan.org/dist/Class-Inspector"
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/Class-Inspector-${pkgver}.tar.gz")
+sha512sums=('980654614d968e2fb61df864322f5c5248e352f0697a425539600c3549505f47b857d7856bc9d406ebc8757f8fc379a669f1f5085412f6fa48672c9db8a82df4')
+
+build() {
+ cd Class-Inspector-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd Class-Inspector-${pkgver}
+ make test
+}
+
+package() {
+ cd Class-Inspector-${pkgver}
+ make DESTDIR="$pkgdir" install
+}