summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-data-uuid/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-data-uuid/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-data-uuid/PKGBUILD67
1 files changed, 28 insertions, 39 deletions
diff --git a/abs/core/perl_modules/perl-data-uuid/PKGBUILD b/abs/core/perl_modules/perl-data-uuid/PKGBUILD
index a20fbe4..69eda71 100644
--- a/abs/core/perl_modules/perl-data-uuid/PKGBUILD
+++ b/abs/core/perl_modules/perl-data-uuid/PKGBUILD
@@ -1,51 +1,40 @@
-# CPAN Name : Data-UUID
-# Contributor: Anonymous
-# Generator : CPANPLUS::Dist::Arch 1.30
+# $Id$
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
-pkgname='perl-data-uuid'
-pkgver='1.221'
-pkgrel='1'
+pkgname=perl-data-uuid
+_perl_namespace=Data
+_perl_module=UUID
+pkgver=1.221
+pkgrel=4
pkgdesc="Globally/Universally Unique Identifiers (GUIDs/UUIDs)"
-arch=('i686' 'x86_64')
-license=('PerlArtistic' 'GPL')
+arch=('x86_64')
+url="https://metacpan.org/release/${_perl_namespace}-${_perl_module}"
+license=('BSD')
+depends=('perl')
+source=("https://www.cpan.org/modules/by-module/${_perl_namespace}/${_perl_namespace}-${_perl_module}-${pkgver}.tar.gz")
+sha256sums=('3cc7b2a3a7b74b45a059e013f7fd878078500ea4b7269036f84556b022078667')
options=('!emptydirs')
-depends=('perl>=0')
-makedepends=()
-url='https://metacpan.org/release/Data-UUID'
-source=('http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-UUID-1.221.tar.gz')
-md5sums=('7619929e8fe205a7fb83bc1c29ecbf99')
-sha512sums=('fa40219890f9adeb486a7ff636603d8695d81765ee858e396130100aaba96b524d80eef76e0c06eac2086fe3bb2d26114d94459466d29ddc82a7a7fcb2f5adac')
-_distdir="Data-UUID-1.221"
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd "${_perl_namespace}-${_perl_module}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ perl Makefile.PL
+ make
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ cd "${_perl_namespace}-${_perl_module}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
}
package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "${_perl_namespace}-${_perl_module}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ make pure_install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+ # Install license file
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "LICENSE"
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: