summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-date-manip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-date-manip/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-date-manip/PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/abs/core/perl_modules/perl-date-manip/PKGBUILD b/abs/core/perl_modules/perl-date-manip/PKGBUILD
index 0ef2f9c..8688fd1 100644
--- a/abs/core/perl_modules/perl-date-manip/PKGBUILD
+++ b/abs/core/perl_modules/perl-date-manip/PKGBUILD
@@ -1,29 +1,31 @@
-# $Id: PKGBUILD 161416 2012-06-11 02:54:05Z eric $
-# Maintainer: Kevin Piche <kevin@archlinux.org>
-# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=perl-date-manip
-_realname=Date-Manip
-pkgver=6.32
+pkgver=6.70
pkgrel=1
pkgdesc="Date::Manip - date manipulation routines"
arch=('any')
license=('PerlArtistic')
-url="http://search.cpan.org/dist/${_realname}/"
-depends=('perl-yaml-syck')
+url="http://search.cpan.org/dist/Date-Manip/"
+depends=('perl')
+checkdepends=('perl-test-inter')
options=('!emptydirs')
-source=(http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/${_realname}-${pkgver}.tar.gz)
-md5sums=('0d5c1ee2f75f6407fb1035e3535f650b')
+source=("http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/Date-Manip-${pkgver}.tar.gz")
+sha512sums=('67550a3f558fa0c075a9fb43bd59b23328d5d55d053c207a92db6a6e18cba6d2f53ca190110d2f1b00338b1e249d7021b3184f3d9f3965cba0160211a64beb26')
build() {
- cd "${srcdir}/${_realname}-${pkgver}"
+ cd Date-Manip-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
- # install module in vendor directories.
- perl Build.PL installdirs=vendor destdir="${pkgdir}"
- perl Build
+check() {
+ cd Date-Manip-${pkgver}
+ make test
}
package() {
- cd "${srcdir}/${_realname}-${pkgver}"
- perl Build install
+ cd Date-Manip-${pkgver}
+ make DESTDIR="${pkgdir}" install
}