summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-date-manip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-date-manip/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-date-manip/PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/abs/core/perl_modules/perl-date-manip/PKGBUILD b/abs/core/perl_modules/perl-date-manip/PKGBUILD
index be50d1a..0ef2f9c 100644
--- a/abs/core/perl_modules/perl-date-manip/PKGBUILD
+++ b/abs/core/perl_modules/perl-date-manip/PKGBUILD
@@ -1,28 +1,29 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 161416 2012-06-11 02:54:05Z eric $
# Maintainer: Kevin Piche <kevin@archlinux.org>
# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
pkgname=perl-date-manip
_realname=Date-Manip
-pkgver=5.54
+pkgver=6.32
pkgrel=1
pkgdesc="Date::Manip - date manipulation routines"
-arch=(i686 x86_64)
+arch=('any')
license=('PerlArtistic')
url="http://search.cpan.org/dist/${_realname}/"
-depends=('perl>=5.10.0')
-options=(!emptydirs)
+depends=('perl-yaml-syck')
+options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/${_realname}-${pkgver}.tar.gz)
-md5sums=('16c343329bad644b17f4f8ec5fb243cf')
+md5sums=('0d5c1ee2f75f6407fb1035e3535f650b')
build() {
- cd ${startdir}/src/${_realname}-${pkgver}
+ cd "${srcdir}/${_realname}-${pkgver}"
+
# install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${startdir}/pkg || return 1
+ perl Build.PL installdirs=vendor destdir="${pkgdir}"
+ perl Build
+}
- # remove perllocal.pod and .packlist
- find ${startdir}/pkg -name perllocal.pod -delete
- find ${startdir}/pkg -name .packlist -delete
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ perl Build install
}