summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-datetime-format-builder/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-datetime-format-builder/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-datetime-format-builder/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-datetime-format-builder/PKGBUILD b/abs/core/perl_modules/perl-datetime-format-builder/PKGBUILD
new file mode 100644
index 0000000..10df715
--- /dev/null
+++ b/abs/core/perl_modules/perl-datetime-format-builder/PKGBUILD
@@ -0,0 +1,28 @@
+# CPAN Name : DateTime-Format-Builder
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
+# Generator : CPANPLUS::Dist::Arch 0.18
+pkgname=perl-datetime-format-builder
+pkgver=0.8000
+pkgrel=3
+pkgdesc="Create DateTime parser classes and objects"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+provides=('perl-datetime-format-builder=0.80')
+depends=('perl' 'perl-class-factory-util>=1.6' 'perl-datetime>=0.12' 'perl-datetime-format-strptime>=1.04' 'perl-params-validate>=0.72')
+url='http://search.cpan.org/dist/DateTime-Format-Builder'
+source=('http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Builder-0.80.tar.gz')
+md5sums=('f6c5d5a17b5b7478ff555a2d3cce5136')
+
+build() {
+ DIST_DIR="${srcdir}/DateTime-Format-Builder-0.80"
+ export PERL_MM_USE_DEFAULT=1
+ { cd "$DIST_DIR" &&
+ perl Makefile.PL INSTALLDIRS=vendor &&
+ make &&
+ make test &&
+ make DESTDIR="$pkgdir" install;
+ } || return 1;
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}