summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD b/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD
index 360b88a..c8e07df 100644
--- a/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD
+++ b/abs/core/perl_modules/perl-datetime-format-iso8601/PKGBUILD
@@ -1,26 +1,32 @@
+# $Id: PKGBUILD 66111 2012-02-23 01:12:06Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Lukas Fleischer <archlinux at cryptocrack dot de>
pkgname=perl-datetime-format-iso8601
-pkgver=0.07
+pkgver=0.08
pkgrel=1
-pkgdesc="Parses ISO8601 formats."
-arch=('i686' 'x86_64')
+pkgdesc="Parses ISO8601 formats"
+arch=('any')
url="http://search.cpan.org/dist/DateTime-Format-ISO8601/"
license=('PerlArtistic')
-depends=('perl-datetime-format-builder>=0.770.0' 'perl-datetime>=0.18')
-#makedepends=('perl-module-build>=0.350.0')
+depends=('perl-datetime-format-builder' 'perl-datetime')
+makedepends=()
optdepends=('perl-file-find-rule'
'perl-test-distribution'
'perl-test-pod')
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/J/JH/JHOBLITT/DateTime-Format-ISO8601-$pkgver.tar.gz")
-md5sums=('debb51180d0318ae09cad01c544a1d7d')
+md5sums=('b7c0a4b5e767a8d3b87f3dc678d8c30c')
build() {
cd $srcdir/DateTime-Format-ISO8601-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR="${pkgdir}" || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/DateTime-Format-ISO8601-$pkgver
+ make install DESTDIR="${pkgdir}"
find ${pkgdir} -name perllocal.pod -delete
find ${pkgdir} -name .packlist -delete
}