summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD b/abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD
index b4b6c6f..8c38e26 100644
--- a/abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD
+++ b/abs/core/perl_modules/perl-datetime-format-mail/PKGBUILD
@@ -2,22 +2,25 @@
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-datetime-format-mail
-pkgver=0.3001
-pkgrel=3
+pkgver=0.403
+pkgrel=2
pkgdesc="Convert between DateTime and RFC2822/822 formats "
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~DROLSKY/DateTime-Format-Mail"
+arch=('x86_64')
+url="http://search.cpan.org/dist/DateTime-Format-Mail"
license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0' 'perl-datetime' 'perl-params-validate>=0.67')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/D/DR/DROLSKY/DateTime-Format-Mail-$pkgver.tar.gz)
-md5sums=('15e36249e866463bd0237262a8e43b16')
+source=("http://search.cpan.org/CPAN/authors/id/B/BO/BOOK/DateTime-Format-Mail-$pkgver.tar.gz")
+md5sums=('b34a52d96290c42cf53e8db0a8f16ecd')
build() {
- cd $startdir/src/DateTime-Format-Mail-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=$startdir/pkg || return 1
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ cd "$srcdir"/DateTime-Format-Mail-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package() {
+ cd "$srcdir"/DateTime-Format-Mail-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
}