summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-dbi-shell/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-dbi-shell/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-dbi-shell/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-dbi-shell/PKGBUILD b/abs/core/perl_modules/perl-dbi-shell/PKGBUILD
new file mode 100644
index 0000000..c14695a
--- /dev/null
+++ b/abs/core/perl_modules/perl-dbi-shell/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-dbi-shell
+pkgver=11.95
+pkgrel=6
+pkgdesc="Perl/CPAN Module DBI::Shell"
+arch=("any")
+url="http://search.cpan.org/dist/DBI-Shell"
+license=("GPL" "PerlArtistic")
+makedepends=("perl-text-reform" "perl-io-tee")
+depends=("perl-text-reform" "perl-io-tee")
+source=("https://www.cpan.org/authors/id/T/TL/TLOWERY/DBI-Shell-$pkgver.tar.gz")
+sha256sums=('44aa76c90a425d4aff9e2580a6baf334a5102fb794fbdb26e301294c190cbed9')
+
+build() {
+ cd "$srcdir"/DBI-Shell-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/DBI-Shell-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
+}