summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-devel-checklib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-devel-checklib/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-devel-checklib/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-devel-checklib/PKGBUILD b/abs/core/perl_modules/perl-devel-checklib/PKGBUILD
new file mode 100644
index 0000000..cfd2a70
--- /dev/null
+++ b/abs/core/perl_modules/perl-devel-checklib/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: pzl <alsoelp _at_ gmail>
+
+pkgname=perl-devel-checklib
+pkgver=1.11
+pkgrel=3
+pkgdesc="Module to check if other perl modules are installed"
+arch=('any')
+url='http://search.cpan.org/dist/Devel-CheckLib/'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+checkdepends=('perl-io-captureoutput')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/M/MA/MATTN/Devel-CheckLib-${pkgver}.tar.gz")
+sha512sums=('21a64cb2ec4f3769d604eba151074daa841d40d2073a93ec186e82d8496f5ca05728c5352a31c4f07765956b85cb3144225edb51b84245b0582267af55ef2e2f')
+
+build() {
+ cd Devel-CheckLib-$pkgver
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd Devel-CheckLib-$pkgver
+ make test
+}
+
+package() {
+ cd Devel-CheckLib-$pkgver
+ make install DESTDIR="$pkgdir"
+}