summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-email-date-format/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-email-date-format/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-email-date-format/PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/abs/core/perl_modules/perl-email-date-format/PKGBUILD b/abs/core/perl_modules/perl-email-date-format/PKGBUILD
index 6625738..a7151d5 100644
--- a/abs/core/perl_modules/perl-email-date-format/PKGBUILD
+++ b/abs/core/perl_modules/perl-email-date-format/PKGBUILD
@@ -1,26 +1,32 @@
-# $Id: PKGBUILD 150522 2012-02-18 12:04:18Z allan $
-# Maintainer:
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Sergej Pupykin <pupykin.s+aur@gmail.com>
pkgname=perl-email-date-format
-pkgver=1.002
+pkgver=1.005
pkgrel=3
pkgdesc="produce RFC 2822 date strings"
arch=('any')
url="http://search.cpan.org/dist/Email-Date-Format"
license=('GPL' 'PerlArtistic')
depends=('perl')
+checkdepends=('perl-test-pod' 'perl-capture-tiny')
options=('!emptydirs')
source=("http://www.cpan.org/authors/id/R/RJ/RJBS/Email-Date-Format-$pkgver.tar.gz")
-md5sums=('7ae25275da6ab272aa8b40141eac9f82')
+md5sums=('030dcee3bc1a44674900b0132925bd03')
build() {
- cd "${srcdir}"/Email-Date-Format-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd Email-Date-Format-$pkgver
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
+check() {
+ cd Email-Date-Format-$pkgver
+ make test
+}
+
package() {
- cd "${srcdir}"/Email-Date-Format-$pkgver
+ cd Email-Date-Format-$pkgver
make DESTDIR="${pkgdir}" install
}