summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-error/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-error/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-error/PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/abs/core/perl_modules/perl-error/PKGBUILD b/abs/core/perl_modules/perl-error/PKGBUILD
index a8fa056..2518c31 100644
--- a/abs/core/perl_modules/perl-error/PKGBUILD
+++ b/abs/core/perl_modules/perl-error/PKGBUILD
@@ -1,34 +1,32 @@
-# $Id: PKGBUILD 163573 2012-07-16 03:20:23Z eric $
-# Maintainer: Dale Blount <dale@archlinux.org>
-# Contributor: Dale Blount <dale@archlinux.org>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=perl-error
-_realname=Error
-pkgver=0.17018
+pkgver=0.17026
pkgrel=1
pkgdesc="Perl/CPAN Error module - Error/exception handling in an OO-ish way"
-url="http://search.cpan.org/dist/${_realname}/"
+url="http://search.cpan.org/dist/Error/"
arch=('any')
license=('PerlArtistic' 'GPL')
-depends=('perl>=5.10.0')
+depends=('perl')
+checkdepends=('perl-test-pod' 'perl-test-pod-coverage')
options=('!emptydirs')
-source=(http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/${_realname}-${pkgver}.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/Error-${pkgver}.tar.gz)
+sha512sums=('58d43a133fb74d94d726ae923cdfb7df8e1faf156247bb07cb7308218e21a627485f031d029b3ee3179d92e756dca7f1e6dd1e2f4378f420c72b171aefe2f410')
build() {
- cd "${srcdir}/${_realname}-${pkgver}"
- # install module in vendor directories.
+ cd Error-${pkgver}
perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "${srcdir}/${_realname}-${pkgver}"
+ cd Error-${pkgver}
make test
}
package() {
- cd "${srcdir}/${_realname}-${pkgver}"
- make install DESTDIR="${pkgdir}"
+ cd Error-${pkgver}
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('1137a7bbb94c9508a2268c467583207f')