summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-file-listing/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-file-listing/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-file-listing/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-file-listing/PKGBUILD b/abs/core/perl_modules/perl-file-listing/PKGBUILD
new file mode 100644
index 0000000..8656fc1
--- /dev/null
+++ b/abs/core/perl_modules/perl-file-listing/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Justin "juster" Davis <jrcd83@gmail.com>
+# $Id: PKGBUILD 150631 2012-02-19 01:02:52Z allan $
+
+pkgname=perl-file-listing
+pkgver=6.04
+pkgrel=1
+pkgdesc="parse directory listing"
+arch=(any)
+license=(PerlArtistic GPL)
+options=(!emptydirs)
+depends=('perl>=5.8.8' 'perl-http-date>=6')
+conflicts=('perl-libwww<6')
+url="http://search.cpan.org/dist/File-Listing"
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/File-Listing-${pkgver}.tar.gz")
+md5sums=('83f636b477741f3a014585bb9cc079a6')
+sha512sums=('a84198bc82003daaf88ed23218e34a7a1552dcd2855a9563e9609ce5df167a8295043501534c31614854fc8dd9c04b4af27b4d7320112c613914f94c86c2eeb2')
+_distdir="${srcdir}/File-Listing-${pkgver}"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_distdir"
+ make test
+ )
+}
+
+package() {
+ cd "$_distdir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: