summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-file-sharedir/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-file-sharedir/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-file-sharedir/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-file-sharedir/PKGBUILD b/abs/core/perl_modules/perl-file-sharedir/PKGBUILD
new file mode 100644
index 0000000..f57b2ba
--- /dev/null
+++ b/abs/core/perl_modules/perl-file-sharedir/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 149415 2012-02-07 16:24:01Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Caleb Cushing <xenoterracide@gmail.com>
+
+pkgname=perl-file-sharedir
+_realname=File-ShareDir
+pkgver=1.03
+pkgrel=2
+pkgdesc="Locate per-dist and per-module shared files"
+arch=(any)
+license=(PerlArtistic GPL)
+depends=(perl-class-inspector)
+url="http://search.cpan.org/dist/File-ShareDir"
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/$_realname-$pkgver.tar.gz")
+md5sums=('333a0903db23b9097adfbeb37b99d561')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}