summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-file-slurp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-file-slurp/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-file-slurp/PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/abs/core/perl_modules/perl-file-slurp/PKGBUILD b/abs/core/perl_modules/perl-file-slurp/PKGBUILD
index 5e96fd8..1db97f1 100644
--- a/abs/core/perl_modules/perl-file-slurp/PKGBUILD
+++ b/abs/core/perl_modules/perl-file-slurp/PKGBUILD
@@ -1,23 +1,29 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-file-slurp
-pkgver=9999.13
-pkgrel=1
+pkgver=9999.19
+pkgrel=4
pkgdesc="Read/write/append files quickly"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~DROLSKY/File-Slurp"
+arch=('any')
+url="http://search.cpan.org/dist/File-Slurp"
license=('GPL' 'PerlArtistic')
-depends=('perl>=5.10.0')
+depends=('perl>=5.14.0')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/D/DR/DROLSKY/File-Slurp-$pkgver.tar.gz)
-md5sums=('ac3cd9d466b99d1534762ff3549aaa66')
+source=(https://www.cpan.org/authors/id/U/UR/URI/File-Slurp-$pkgver.tar.gz)
+sha256sums=('ce29ebe995097ebd6e9bc03284714cdfa0c46dc94f6b14a56980747ea3253643')
build() {
- cd $startdir/src/File-Slurp-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=$startdir/pkg || return 1
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ cd "$srcdir"/File-Slurp-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/File-Slurp-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
}