summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-html-parser/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-html-parser/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-html-parser/PKGBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/abs/core/perl_modules/perl-html-parser/PKGBUILD b/abs/core/perl_modules/perl-html-parser/PKGBUILD
index b30443f..172a9fe 100644
--- a/abs/core/perl_modules/perl-html-parser/PKGBUILD
+++ b/abs/core/perl_modules/perl-html-parser/PKGBUILD
@@ -1,35 +1,41 @@
-# $Id: PKGBUILD 160535 2012-06-02 10:27:46Z bluewind $
-# Maintainer: kevin <kevin@archlinux.org>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: kevin <kevin@archlinux.org>
# Contributor: Manolis Tzanidakis
-# Contributor: Firmicus <francois.archlinux.org>
+# Contributor: Firmicus <francois.archlinux.org>
pkgname=perl-html-parser
-_realname=HTML-Parser
-pkgver=3.69
-pkgrel=2
+pkgver=3.72
+pkgrel=5
pkgdesc="Perl HTML parser class"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('PerlArtistic')
-url="http://search.cpan.org/dist/${_realname}/"
-depends=('perl-html-tagset' 'perl>=5.12.1')
-options=(!emptydirs)
-source=(http://www.cpan.org/authors/id/G/GA/GAAS/${_realname}-${pkgver}.tar.gz)
-md5sums=('d22cc6468ce670a56034be907e4e7c54')
+url="http://search.cpan.org/dist/HTML-Parser/"
+depends=('perl-html-tagset')
+checkdepends=('perl-test-pod')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/G/GA/GAAS/HTML-Parser-${pkgver}.tar.gz)
+md5sums=('eb7505e5f626913350df9dd4a03d54a8')
build() {
- cd "${srcdir}/${_realname}-${pkgver}"
- # install module in vendor directories.
+ cd HTML-Parser-${pkgver}
perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "${srcdir}/${_realname}-${pkgver}"
+ cd HTML-Parser-${pkgver}
make test
}
package() {
- cd "${srcdir}/${_realname}-${pkgver}"
+ cd HTML-Parser-${pkgver}
make install DESTDIR="${pkgdir}"
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
}
-# vim: ts=2 sw=2 et ft=sh