summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-io-html/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-io-html/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-io-html/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-io-html/PKGBUILD b/abs/core/perl_modules/perl-io-html/PKGBUILD
new file mode 100644
index 0000000..7a86226
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-html/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=perl-io-html
+pkgver=1.001
+pkgrel=3
+pkgdesc="Open an HTML file with automatic charset detection"
+arch=('any')
+url='http://search.cpan.org/dist/IO-HTML'
+depends=('perl')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/C/CJ/CJM/IO-HTML-$pkgver.tar.gz)
+sha1sums=('210b60f438502744c9c31a82329b19a6f9aecf63')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_MM_OPT="INSTALLDIRS=vendor" \
+ PERL_MB_OPT="--installdirs vendor"
+ cd IO-HTML-$pkgver
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd IO-HTML-$pkgver
+ make test
+}
+
+package() {
+ cd IO-HTML-$pkgver
+ make DESTDIR="$pkgdir" install
+}