summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-io-tty/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-io-tty/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-io-tty/PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/abs/core/perl_modules/perl-io-tty/PKGBUILD b/abs/core/perl_modules/perl-io-tty/PKGBUILD
index 540af17..0812643 100644
--- a/abs/core/perl_modules/perl-io-tty/PKGBUILD
+++ b/abs/core/perl_modules/perl-io-tty/PKGBUILD
@@ -1,27 +1,34 @@
-# $Id: PKGBUILD 71803 2012-06-02 10:31:14Z bluewind $
+# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Charles Mauch <cmauch@gmail.com>
pkgname=perl-io-tty
-pkgver=1.10
-pkgrel=2
+pkgver=1.12
+pkgrel=6
pkgdesc="Provide an interface to TTYs and PTYs"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://search.cpan.org/dist/IO-Tty/"
license=("GPL" "PerlArtistic")
depends=('glibc')
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/IO-Tty-$pkgver.tar.gz")
-md5sums=('46baec86a145e57f0ec661fa412b097c')
+md5sums=('11695a1a516b3bd1b90ce75ff0ce3e6d')
build() {
- cd $srcdir/IO-Tty-$pkgver
+ cd "$srcdir"/IO-Tty-$pkgver
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
-package(){
- cd $srcdir/IO-Tty-$pkgver
- make install DESTDIR=$pkgdir
- find $pkgdir -name '.packlist' -delete
- find $pkgdir -name '*.pod' -delete
+package() {
+ cd "$srcdir"/IO-Tty-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
}