summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-ipc-run3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-ipc-run3/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-ipc-run3/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-ipc-run3/PKGBUILD b/abs/core/perl_modules/perl-ipc-run3/PKGBUILD
new file mode 100644
index 0000000..e5d240e
--- /dev/null
+++ b/abs/core/perl_modules/perl-ipc-run3/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Rémy Oudompheng <remy@archlinux.org>
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.27
+
+pkgname='perl-ipc-run3'
+_dist=IPC-Run3
+pkgver=0.048
+pkgrel=4
+pkgdesc="run a subprocess with input/ouput redirection"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/IPC-Run3'
+source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/${_dist}-${pkgver}.tar.gz")
+md5sums=('5a8cec571c51a118b265cf6e24e55761')
+sha512sums=('50432850d8dccd2e59aa6684d34f3e3242fd7df3eb4d9a5eb02dae389aa46b5fd68cc54114a157c3fe99956e68e74d575ab3db5009b7bf7d5c325f1f109b1262')
+
+build() {
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}
+