summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-libwww/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-libwww/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-libwww/PKGBUILD73
1 files changed, 47 insertions, 26 deletions
diff --git a/abs/core/perl_modules/perl-libwww/PKGBUILD b/abs/core/perl_modules/perl-libwww/PKGBUILD
index 254519a..8aec958 100644
--- a/abs/core/perl_modules/perl-libwww/PKGBUILD
+++ b/abs/core/perl_modules/perl-libwww/PKGBUILD
@@ -1,32 +1,53 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Kevin Piche <kevin@archlinux.org>
-# Contributor: Manolis Tzanidakis
+# Packager: Justin "juster" Davis <jrcd83@gmail.com>
+# $Id: PKGBUILD 150749 2012-02-21 19:40:54Z juster $
pkgname=perl-libwww
-_realname=libwww-perl
-pkgver=5.808
-pkgrel=2
-pkgdesc="A set of Perl modules which provides a simple and consistent API to the WWW."
-arch=(i686 x86_64)
-license=('PerlArtistic')
-url="http://search.cpan.org/dist/${_realname}/"
-depends=('perl-uri' 'perl-html-parser' 'perl>=5.10.0')
-
+pkgver=6.04
+pkgrel=1
+pkgdesc="The World-Wide Web library for Perl"
+arch=(any)
+license=(PerlArtistic GPL)
options=(!emptydirs)
-replaces=('libwww-perl')
-provides=('libwww-perl')
-source=(http://www.cpan.org/authors/id/G/GA/GAAS/${_realname}-${pkgver}.tar.gz)
-md5sums=('72120d9195ab1649c2d787eb1102a90c')
+depends=('perl>=5.8.1' 'perl-encode-locale' 'perl-file-listing>=6'
+ 'perl-html-parser' 'perl-http-cookies>=6' 'perl-http-daemon>=6'
+ 'perl-http-date>=6' 'perl-http-negotiate>=6' 'perl-lwp-mediatypes>=6'
+ 'perl-net-http>=6' 'perl-uri>=1.10' 'perl-www-robotrules>=6'
+ 'perl-http-message>=6')
+optdepends=('perl-lwp-protocol-https: for https:// url schemes')
+url=https://metacpan.org/release/libwww-perl
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/libwww-perl-${pkgver}.tar.gz")
+md5sums=(24acf2fe33b2295f048f8859e9665ee3)
+sha512sums=(9ea578e6da99e4002a35ae82d1ee025caf15b3bc7e40fbe71abd7e8592036f16bd0268453dfeedc2c445d957c45ec473b1ed4a1738b644d475d65f7cbdb6927b)
+_distdir="${srcdir}/libwww-perl-${pkgver}"
+
+build()
+(
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
-build() {
- cd ${startdir}/src/${_realname}-${pkgver}
- # install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${startdir}/pkg || return 1
+ cd "$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+)
- # remove perllocal.pod and .packlist
- find ${startdir}/pkg -name perllocal.pod -delete
- find ${startdir}/pkg -name .packlist -delete
+check()
+(
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_distdir"
+ make test
+)
+
+package() {
+ cd "$_distdir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-# vim: ts=2 sw=2 et ft=sh
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: