summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-lwp-mediatypes/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-lwp-mediatypes/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-lwp-mediatypes/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-lwp-mediatypes/PKGBUILD b/abs/core/perl_modules/perl-lwp-mediatypes/PKGBUILD
new file mode 100644
index 0000000..625b2bd
--- /dev/null
+++ b/abs/core/perl_modules/perl-lwp-mediatypes/PKGBUILD
@@ -0,0 +1,49 @@
+# Packager: Justin "juster" Davis <jrcd83@gmail.com>
+# $Id: PKGBUILD 150744 2012-02-21 19:28:44Z juster $
+
+pkgname=perl-lwp-mediatypes
+pkgver=6.02
+pkgrel=1
+pkgdesc="guess media type for a file or a URL"
+arch=(any)
+license=(PerlArtistic GPL)
+options=(!emptydirs)
+depends=('perl>=5.6.2')
+conflicts=('perl-libwww<6')
+url=https://metacpan.org/release/LWP-MediaTypes
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/LWP-MediaTypes-${pkgver}.tar.gz")
+md5sums=(8c5f25fb64b974d22aff424476ba13c9)
+sha512sums=(b2ad33fb2c6dd7afaa9b8dd2ed6a15b2ecc35d13bcdf5297ce1632ea77406def0840a24c5213187707b665f28cc9bbea5774bfd1a4070d1f6192e904f707b94e)
+_distdir="${srcdir}/LWP-MediaTypes-${pkgver}"
+
+build()
+(
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+)
+
+check()
+(
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_distdir"
+ make test
+)
+
+package() {
+ cd "$_distdir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: