summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-math-round/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-math-round/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-math-round/PKGBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/abs/core/perl_modules/perl-math-round/PKGBUILD b/abs/core/perl_modules/perl-math-round/PKGBUILD
index 6501887..2881d28 100644
--- a/abs/core/perl_modules/perl-math-round/PKGBUILD
+++ b/abs/core/perl_modules/perl-math-round/PKGBUILD
@@ -1,22 +1,34 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# $Id: PKGBUILD 143938 2011-11-30 21:38:22Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-math-round
pkgver=0.06
-pkgrel=2
+pkgrel=5
pkgdesc="Perl extension for rounding numbers"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://search.cpan.org/dist/Math-Round"
license=('GPL' 'PerlArtistic')
-depends=('perl>=5.10.0')
+depends=('perl')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/G/GR/GROMMEL/Math-Round-$pkgver.tar.gz)
+source=("http://www.cpan.org/authors/id/G/GR/GROMMEL/Math-Round-$pkgver.tar.gz")
md5sums=('552cef2753b246f97a6e20d8dee66e7c')
build() {
- cd $startdir/src/Math-Round-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=$startdir/pkg || return 1
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ cd "${srcdir}/Math-Round-${pkgver}"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${srcdir}/Math-Round-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/Math-Round-${pkgver}"
+ make install DESTDIR=${pkgdir}
+
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name '*.pod' -delete
}